Handoff and Continuity Not Working For Me

Discussion in 'iOS 8' started by akishore, Jun 3, 2014.

  1. akishore macrumors newbie

    Joined:
    Jun 3, 2014
    #1
    Hi all,

    So I upgraded my MacBook Pro Mid 2009 to Yosemite and upgraded my iPhone 5S to iOS 8. I've been trying this whole handoff and continuity stuff, but nothing is happening. This should be working correctly in the preview versions right?

    What am I missing? Is my Mac too old? I'm on the same Wifi network and their official website states it will work for iMessage, Mail, etc, but nothing at all happens when I try this.

    Any help would be greatly appreciated!
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2

    Is the little icon not showing up on your lock screen on the bottom right? (Opposite the camera icon)
     
  3. akishore thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #3
    Nope, no icon is showing up at all. I've gone into System Preferences, General and checked the "Allow handoff between this Mac and your iCloud devices", but still get nothing.

    I saw another thread here where people were saying it requires Bluetooth LE, but the Apple website here clearly states that it only requires the same Wi-Fi network:

    http://www.apple.com/ios/ios8/continuity/

    Well, it says that under the "answering the call" section where you can see a call show up on your Mac when it comes to your iPhone, however, that doesn't work for me either.
     
  4. ben123456 macrumors regular

    Joined:
    Jan 22, 2012
    #4
    I think the calling on the Mac is not enabled yet if I'm correct
     
  5. chekz0414 macrumors 6502a

    chekz0414

    Joined:
    Jul 3, 2011
    Location:
    FL
    #5
    I don't believe calling is working, but SMS is, I received an SMS on my iPhone and it came through on my Mac too, I dunno if sending SMS from Mac is working yet however.
     
  6. Silverbird0000 macrumors 6502a

    Joined:
    Sep 19, 2006
    Location:
    Fort Myers, FL
    #6
    Mine wasn't working, but I got it working by turning on bluetooth on both my 2012 rMBP and my iPhone 5s. Then restarted both, after that it worked perfectly. It if you turn off bluetooth on the phone, then back on, it will cease to function properly, requiring a complete restart of the phone, then handoff will work again.
     
  7. funkdoc23 macrumors regular

    funkdoc23

    Joined:
    Sep 14, 2012
    #7
    This seems to be the magic solution... Had the same problem and it's what got it working for me again. (It's connected to my mac with bluetooth)
     
  8. cpenner macrumors regular

    Joined:
    Aug 19, 2013
    #8
    Without changing anything, handoff just started working for me today...
     
  9. mitchsaunders macrumors 6502

    Joined:
    Jun 7, 2014
    Location:
    Brisbane, Australia
    #9
    This isn't working for me - rMBP late 2013 with DP3, and iOS 8 beta 3 iPhone 4S - I have tried resetting iCloud on both devices, depaired both from BT, but not re-paired yet? (I heard you don't need to) but Bluetooth is turned on, on both devices.
    Help?
     
  10. langscinema macrumors member

    Joined:
    Jun 5, 2014
    #10
    continuity hasn't worked for me from the start of beta 1
    i'm running 5s and MBA mid 2011
    i do get sms and also some calling features.....many of the calling features activate the FaceTime app on OS X so it does not work all the time

    Question, to those who get continuity to work......does your bluetooth symbol up in the status bar of your mac change from idle to paired? (attached photo)
    Whenever i try to force connection it'll change for a brief second as showing paired but then drops connection

    I recall seeing some screenshots from the keynote where the icon on the iMac was showing paired so I'm guessing that continues to be my challenge
     

    Attached Files:

  11. mitchsaunders macrumors 6502

    Joined:
    Jun 7, 2014
    Location:
    Brisbane, Australia
    #11
    Yeah, nothing for me works.

    ----------

    This might be the magic trackpad and keyboard that's paired to the iMac.
     
  12. vivalavisca macrumors newbie

    Joined:
    Sep 2, 2014
    #12
    Handoff/Continuity not working at all.

    I have an iPhone 5s with iOS8 latest dev preview as of 08/02/14 and a MacBook Pro 15 Retina late 2013 with Yosemite OS X 10.10 developer preview 7.:mad:
     
  13. GaresTaylan macrumors 6502a

    Joined:
    Nov 11, 2009
    #13
    Same for me. 5S and latest model 13" rMBP.
     
  14. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #14
    I get calls and SMS on my Mac just fine, but no handoff...

    I'm using a 5s and a 2012 MacBook Air.
     
  15. cmChimera macrumors 68040

    cmChimera

    Joined:
    Feb 12, 2010
    #15
    Pretty sure you'll have to wait for the GM for this to work again, at least for handoff. I can't even airdrop to/from DP7. I can receive phone calls, and sms. That's about it. Wait for the GM, and it should work again.
     
  16. Dan70 macrumors regular

    Joined:
    Aug 4, 2014
    Location:
    England
    #16
    Are you on iOS 8 beta 5 and Yosemite Dev preview 5 or above?

    Once I matched both version Handoff and Continuity started working.

    I've been able to get calls and SMS through all my iCloud devices.
     
  17. chekz0414 macrumors 6502a

    chekz0414

    Joined:
    Jul 3, 2011
    Location:
    FL
    #17
    Yup Calls and SMS work on DP 7 and Beta 5. Handoff still a no (MacBook Pro 2011)
     
  18. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #18
    that screenshot is just the mac using iPhone as a hotspot nothing to do with getting Continuity working
     
  19. SMIDG3T Suspended

    SMIDG3T

    Joined:
    Apr 29, 2012
    Location:
    England
    #19
    People think that downloading DP7 will fix it. It won't. It doesn't work in beta 5 so until we see the GM on Tuesday, you'll have to wait for Handoff. If it still doesn't work, then it's DP7.
     
  20. clubtech macrumors member

    Joined:
    Jan 2, 2009
    #20

    Just got the GM AND DP7 and sadly it's still not working.
     
  21. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #21
    Probably in the next DP of OS X it should work.
     
  22. clubtech macrumors member

    Joined:
    Jan 2, 2009
    #22
    I stand corrected. It DOES work. I had to sign out of i cloud on both the iPhone and the Mac, then sign back in and after about 10 minutes it started to work.
     
  23. zhandri macrumors 6502

    Joined:
    Sep 4, 2012
  24. shanson27 macrumors 6502a

    shanson27

    Joined:
    Nov 27, 2011
    #24
    I have MacBook pro early 2011 and OS X Yosemite beta 7 and my iPhone 5S is running iOS 8, but nothing works continuity, hotspot, handoff, calling, messages, nothing!
     
  25. mkivgli macrumors newbie

    Joined:
    Sep 19, 2014
    #25
    I just received my iPhone 6 and nothing was working. I enabled bluetooth, still nothing. I finally turned iCloud entirely off on my computer, then turned it right back on. Everything started working immediately.
     

Share This Page