Handoff Breakdown With Activation Tool

Discussion in 'OS X Yosemite (10.10)' started by UncleSchnitty, Oct 17, 2014.

  1. mulepose macrumors newbie

    Joined:
    May 6, 2015
    #801
    iMac early 2009?

    I have an iMac early 2009 with a Broadcom BCM43xx 1.0 (5.106.98.100.24) WiFi card. It seems to be somewhat the same as in my iMac late 2013 (although the numbers in the parentheses are not quite the same). System information says that handoff is not supported (off course, there's no Bluetooth 4.0) but that AirDrop is supported. Will the Continuity Activation Tool work without me having to install a new Airport Extreme card?
     
  2. threluja macrumors newbie

    Joined:
    Oct 19, 2014
    #802
    10.10.4 working fine too :)

    Just reapply your old Kexts (for those of us working manually)
     
  3. Fearz macrumors newbie

    Joined:
    Sep 16, 2012
    #803
    MBP 13" Late-2011

    Any success stories with a MBP 13" Late-2011?

    Can someone post links for compatible airport extreme cards to buy?
     
  4. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #804
    Read the opening post. You will find the answer there.
     
  5. 01mggt macrumors 6502

    Joined:
    Jun 23, 2010
    #805
    Does someone have a mirror to this tool I can download from? I have downloaded it twice now from github and it extracts automatically but when I try to run the app from the folder it tells me it is damaged and asks if I want to move it to the trash.
     
  6. 01mggt macrumors 6502

    Joined:
    Jun 23, 2010
    #806
    Never mind, seems gatekeeper was getting in the way :)
     
  7. jaubele macrumors newbie

    Joined:
    Sep 7, 2007
    #807
    MacBook Pro 2010 15" with BCM94331PCIEBT4CAX Handoff not working, i run CAT 2.0 everything is OK, but not Handoff working.
     
  8. Marc ou Net, Jun 15, 2015
    Last edited: Jun 16, 2015

    Marc ou Net macrumors newbie

    Joined:
    Jun 15, 2015
    #808
    Hi! Like the graphic on the github page of CAT, I baught au Bluetooth 4 dongle (with BCM20702 chip), but event the CAT diagnostic said it's OK with my MacBook Pro mid-10, Handoff not working.
    For explanations, I can associate my iPhone and my Mac but I can't connect each other. (T_T)
    I detected some bigger problem since I patched my computer. Sometimes it blocks with strange draws on the screen. It take 30 seconds to 1 minute and after that keyboard and mouse doesn't react. The only solution is to restart the computer. I take some picture of the screen that I put after le diagnostic.
    Sorry for my poor english.

    This is the diagnostic after applying the patch :
    --- OS X Continuity Activation Tool 2.0.0 ---

    by dokterdok



    --- Initiating system compatiblity check ---



    --- Hardware/OS checks ---

    Verifying Continuity status... OK. OS X reports Continuity as active

    Verifying Mac model reference... OK. Known compatible Mac Model detected: MacBookPro6,2

    Verifying Mac board-id... OK. Short board id detected: Mac-F22586C8

    Verifying OS X version... OK. Mac OS X 10.10.3 (14D136) detected

    Verifying Wi-Fi hardware... OK. A Broadcom AirPort card is active, and is using the Continuity compatible Brcm4360 kext

    Verifying AWDL status... OK. An AWDL interface is up, Wi-Fi is ready for Continuity

    Verifying Bluetooth hardware... OK. 3rd party Bluetooth hardware detected

    Verifying Bluetooth version... OK. Bluetooth 4.0 detected

    Verifying Bluetooth features... OK. Bluetooth features are Continuity compliant

    Verifying Bluetooth firmware... OK. Bluetooth firmware version: v14 c4096



    --- Modifications check ---

    Verifying OS kext protection... OK. Kext developer mode is already active

    Verifying kexts readability... OK. Wi-Fi and Bluetooth kexts were found and could be read

    Verifying Bluetooth blacklist status... OK. Your Mac model is not blacklisted

    Verifying Wi-Fi whitelist status... OK. The whitelist is correctly patched with your board-id

    Verifying old Wi-Fi kext presence... OK. Legacy Wi-Fi driver Brcm4331 was already removed

    Verifying legacy Wi-Fi card patch... OK. The patch is already done. Old Broadcom Wi-Fi cards may work.

    Verifying BT4 dongles compatibility... OK. The patch that enables BT4 USB dongles compatibility has already been applied
    IMG_0261.jpg IMG_0261.jpg IMG_0262.jpg IMG_0263.jpg
     
  9. davshirley macrumors newbie

    Joined:
    Jul 3, 2015
    #809
    I have CAT working with 10.10.4

    Just updated and installed. Everything went well.
     
  10. 6836838 Suspended

    Joined:
    Jul 18, 2011
  11. slvrscoobie, Jul 9, 2015
    Last edited: Sep 1, 2015
  12. slvrscoobie, Jul 9, 2015
    Last edited: Sep 1, 2015
  13. psycho93 macrumors member

    psycho93

    Joined:
    Sep 1, 2010
    Location:
    Ireland
    #813
    have updated to Public Beta 2 iOS 9 on both my iPhone 5s and iPad Air and both are handing off fine to my Mid 2011 MacBook Air which has this Tool. However i'm slow to install the Public @eta 2 El Capitan having read the above posts! anyone else have it working? thanks
     
  14. Mighty Boo, Aug 17, 2015
    Last edited: Aug 17, 2015

    Mighty Boo macrumors newbie

    Joined:
    Aug 17, 2015
    #814
    Handoff confirm works on Macbook Pro Mid 2010 6,2 Yosemite 10.10.5 using CAT app, the correct connection for the antennas are:

    J3 - Longest
    J0 - Medium
    J2 - Shortest

    If you connect to J3, J0 and J1, with J2 not connected, you will experience minor network packet loss and subpar transfer speed on 5Ghz

    If you connect to J3, J1, J2, with J0 not connected, your 5GHz will be very very slow.

    Currently, i have J3, J0 and J2 connected, with J1 not connected, no network packet loss and normal data transfer speed as expected on 5Ghz.

    The ribbon cable is now longer due to the placement of the wifi card, closed the back cover of the MBP and sandwiched it. Its seems okay.

    -------

    I placed a piece of paper between the disc drive and the wifi card, to prevent potential shorting, as the disc drive is metal.

    -------

    My cut out (using a xacto knife, and filing using my wife's nail filer!) for the plastic tray container that holds the wifi card is very similar to the picture in this forum thread: http://forums.macresource.com/read.php?1,1788738,1788738

    This is where i purchased my wifi card ($36USD): http://www.aliexpress.com/item/Free...acbook-Pro-Unibody-A1278-2012/2033102338.html


     
  15. ebernet macrumors member

    Joined:
    Apr 5, 2005
    Location:
    Seattle, WA
    #815
    I have two machines, a late 20-11 macBook Pro 15" with the updated Broadcom card from a mid 2012, and a 2008 Mac Pro with the updated BT/WifiAC card. Both machines worked fine with CAT up until 10.0.5. Now they both do not work, both getting stuck at the same place in the install (after the prompt to plug in a BT dongle if you have one). The terminal is not frozen - I have seen the title alternate between head, bash, etc. It looks as if it is trying to do something, but it continues for hours on end with no change. Can anyone help me? Thanks!
     
  16. elsergio2448 macrumors newbie

    elsergio2448

    Joined:
    Aug 30, 2015
    #816
    Hello, my iMac9,1 24 "early 2009, works with a Dongle Asus BT400.
    Everything was correct and without further modifications. Commenting that the internal wifi is:
    Card Type: AirPort Extreme (0x14E4, 0x8E)
    Firmware Version: Broadcom BCM43xx 1.0 (7.15.166.24.3).
    :):):)
     
  17. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #817


    The drive vibrates. Paper is not a good material for insulation in that scenario.
     
  18. slvrscoobie macrumors 6502a

    slvrscoobie

    Joined:
    Mar 24, 2013
    Location:
    NJ
    #818
    Handoff is only partially working in PB 6 for me on CAX modified 17" 2011 MBP. Airdrop works, but instant hotspot and handoff are not showing up on iphone 6 or ipad mini 2
     
  19. slvrscoobie macrumors 6502a

    slvrscoobie

    Joined:
    Mar 24, 2013
    Location:
    NJ
    #819
    CONTINUITY IS NOW FUNCTIONAL WITH EL CAP GM!
    You need to replace the CloudpairD service with one from Yosemite. Ive attached a zip which includes the 10.10.2 which works on my 2011 MBP with CAX replaced BTLE card.
    Handoff works on ipad and instant hotspot works as well.
     

    Attached Files:

  20. adir macrumors newbie

    Joined:
    Sep 10, 2015
    #820
    I have just bought an iogear bluetooth dongle, plugged it in and installed the activation tool, airdrop now works but handoff doesn't seem to be working, I've opened either mail/safari on my iPhone or on my mac but can't see it on my mac or iPhone. I made sure handoff between apps is enabled on both devices and resigned to my iCloud account, also bluetooth is turned on on both devices, what am I doing wrong?
    This is on a macbook pro early 2011

    EDIT: Nevermind, works like a charm!
    Thanks!
     
  21. martinzsmitt, Sep 10, 2015
    Last edited: Sep 10, 2015

    martinzsmitt macrumors newbie

    Joined:
    Sep 30, 2014
    #821
    very thx! all working!
     
  22. sqvarepants macrumors member

    sqvarepants

    Joined:
    Nov 24, 2014
    Location:
    Madrid
    #822
    I have an iMac 2011 with the BTLE card replaced and after install El Capitan GM, handoff stop working, in system preferences appears activated handoff but don't works

    Do I need to replace that file? In Yosemite works perfectly without any activation tool

    Thanks
     
  23. martinzsmitt macrumors newbie

    Joined:
    Sep 30, 2014
    #823
    you need to use the file attached http://forums.macrumors.com/threads...activation-tool.1803192/page-33#post-21810437
    Then you need to reboot into recovery mode (you need to do this anyway for CAT)
    in recovery mode, go to terminal and disable the system integrity protection with
    CSRUtil Disable
    it should tell you its now disabled.
    reboot and copy that file I linked to /system/library/coreservices/ with the go to folder command in finder
    (you may want to rename the existing one before you overwrite it)
    Then run CAT as normal, reboot and should be good to go
     
  24. sqvarepants macrumors member

    sqvarepants

    Joined:
    Nov 24, 2014
    Location:
    Madrid
    #824

    Thank you for the explanation, works perfect now!
     
  25. elsergio2448 macrumors newbie

    elsergio2448

    Joined:
    Aug 30, 2015
    #825
    hello, in Yosemite it worked fine on my computer using the patch , but in Capitan 10.11.1 gives me the following error :

    Verifying Bluetooth version... /Users/sergio/Downloads/Continuity-Activation-Tool-master/Continuity Activation Tool.app/Contents/Resources/contitool.sh: line 357: [: 6

    6

    4: integer expression expected

    NOT OK. Your hardware doesn't support Bluetooth 4.0, necessary for Continuity Current LMP Version=6

    6

    4, expected 6. Aborting.


    any help? Thank you
     

Share This Page