Handoff does not work from my Mac Mini to my iPhone or iPad

Discussion in 'OS X Yosemite (10.10)' started by docprego, Nov 9, 2014.

  1. docprego macrumors 65816

    Joined:
    Jun 12, 2007
    Location:
    Henderson, NV
    #1
    I have handoff setup among my three Apple products:

    1. 2012 Mac Mini server running Yosemite 10.10
    2. IPad air running iOS 8.1
    3. iPhone 6 Plus running iOS 8.1

    Everything works great between my iPhone and iPad air. When I open a handoff app on one device the other immediately responds with the expected handoff icon in the lock and multitasking screens. Everything also works great from the iPad Air and iPhone 6 Plus to my Mac Mini. I see the handoff icon to the left of the dock.

    But nothing works when I start a handoff compatible app on the Mac Mini, none of my other devices recognize the handoff and the icon never appears on the lock or multitasking screens.

    I have wifi turned on for all 3 devices and connected to the same network. Bluetooth is also on for all 3 devices. I've checked the options in system preferences and settings on all 3 devices to allow handoff, yet still nothing. I've signed in and out of iCloud on the Mac Mini but it's made no difference. It's like my handoff works in only one direction with my Mac Mini and that's to the Mini but not from it.

    Any ideas? This is driving me crazy.
     
  2. docprego thread starter macrumors 65816

    Joined:
    Jun 12, 2007
    Location:
    Henderson, NV
    #2
    Well I followed some advice I found somewhere to do the following (the order is apparently important):

    1. Sign out of iCloud on my Mac
    2. Sign out of iCloud on my iPhone
    3. Sign out of iCloud on my iPad Air

    Then restart all 3 devices. Once booted back up, sign into icloud in the same order I signed out above.

    After doing this almost everything was working. I only had one glitch where the iPad would not trigger handoff on the Mac. So I logged out of iCloud on the iPad again and signed back in. This time for whatever reason it worked.

    I can now handoff between all 3 devices in either direction.

    Hope that might help someone in the same boat.
     

Share This Page