Handoff not working

Discussion in 'Mac Pro' started by astonius86, Apr 26, 2017.

  1. astonius86, Apr 26, 2017
    Last edited: Apr 26, 2017

    astonius86 macrumors newbie

    Joined:
    Apr 25, 2017
    Location:
    Bentonville, AR
    #1
    I have a 2010 Mac Pro with upgraded wifi/bluetooth from OSXWiFi.com. Both wifi and bluetooth appear to be working fine as far as internet and peripherals are concerned, but I cannot get Handoff working properly. System Profiler shows Handoff as supported, but Universal Clipboard, app switching, and Instant Hot Spot are not working. Text messages, phone calls, and AirDrop are working, however. I have tried everything I know to do, including logging out of iCloud on both devices, resetting SMU/PRAM on the Mac Pro, turning off bluetooth/wifi on both devices, restarting the devices, deleting the bluetooth plist on the desktop, and disabling/reenabling Handoff on both devices. Nothing works! What else can I try?
     
  2. astonius86 thread starter macrumors newbie

    Joined:
    Apr 25, 2017
    Location:
    Bentonville, AR
    #2
    I've spent several hours over the past two days trying to get this working, and it still eludes me. Most of that time spent was looking through different elements of the Bluetooth Explorer included in the additional tools for xcode. I compared what I was seeing in my 2012 rMBP (where Handoff is working properly) and on my Mac Pro, and I noticed even though the Mac Pro sees the LE endpoint on my phone there's a discrepancy in the address type. The MBP sees the type as Public and shows the full name of my phone. The MP on the other hand sees the type as Random and just says "iPhone". I have to imagine this plays some sort of role, but I can't figure out a way to fix it.
     
  3. mattspace macrumors 6502a

    mattspace

    Joined:
    Jun 5, 2013
    Location:
    Australia
    #3
    I've had it work, and then cease working, and then start again. Personally, I think it's a janky technology.

    My 4,1->5,1 has Airdrop working, it shows and has the ability to answer standard phone calls that are coming in to my phone, but app switching only worked for a very short window. I think it has a lot to do with how in sync the versions of iOS, macOS, and the apps are respectively. For example, iOS 10.2 took away the ability for iCloud tabs to work on safari on Yosemite in my case - the iOS devices can see the mac's safari tabs, but not the reverse.
     
  4. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    First of all, Continuity, Airdrop, and Handoff are independent. What you get is continuity (messages, phone call), this can work even without wi-fi.

    Airdrop of course need wi-fi, but it's much more reliable then Handoff. No matter Handoff work or not, Airdrop can work flawlessly.

    Some you didn't mention about CAT. I think that's the very 1st thing you should try (remember to disable SIP if applicable).

    In general, if Handoff / personal hotspot stop working. The best action is just logoff iCloud (on both computer and iPhone), shutdown (both computer and iPhone), wait few min (e.g. 5min), restart them, and login iCloud again. It may take few more min before Handoff and work properly after iCloud login.

    If you already did that. Then TBH, nothing you can do. And it seems Handoff / personal hotspot is not that reliable. Even though you make it work, they may suddenly stop working again, and may be self recover later.
     
  5. Gazember macrumors member

    Joined:
    Apr 5, 2017
    #5
    Exactly my observation. I have too spent days on this with my cMP. I have upgraded the card to BT 4.0 and Handoff works about half the time. Moving the antenna around in the case helped to get there from near zero success. I think the thick metal case shields too muck of the signal.
     
  6. astonius86 thread starter macrumors newbie

    Joined:
    Apr 25, 2017
    Location:
    Bentonville, AR
    #6
    Thanks for the info. I wouldn't think I'd need to run CAT since System Profiler already shows Handoff as supported, and others have gotten the Broadcom chip to work without it. I also don't think it's a bluetooth antenna issue since I can see the LE address of the phone. It's like the phone isn't broadcasting the Public LE address to my Mac Pro for whatever reason. I had some of my coworkers with BLE chips also run the Bluetooth Explorer, and like my Mac Pro they also see my Random LE address but not the public one. I'm guessing iCloud somehow controls access to the Public address, but my iCloud account is not allowing the connection between the Mac Pro and my iPhone 7 :(
     
  7. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #7
    It's hard to tell. Quite a few of us has the Broadcom card, and still required run CAT to make things work (e.g. Apple Watch unlock). As long as you have a good backup. It's worth to try.

    Since your Airdrop work fine. I also agree that's not because of the antenna issue.
     
  8. astonius86 thread starter macrumors newbie

    Joined:
    Apr 25, 2017
    Location:
    Bentonville, AR
    #8
    Well I'll be damned. I decided to give the CAT a try and sure enough it worked (after disabling SIP of course). Perhaps there's a slight firmware discrepancy or something? Anyway, thank you very much for the recommendation.

    As an aside I checked the Bluetooth Explorer again after Handoff started working, and my LE address type is now public, so that definitely plays a role.
     
  9. haralds macrumors 6502

    haralds

    Joined:
    Jan 3, 2014
    Location:
    Silicon Valley, CA
    #9
    I have a similar odd situation. After much grief, I have given up. In my case, Handoff is working with my iPad Air 2 but not the 7 Plus. I have toggled iCloud, but with my huge mail db its a real pain.
     
  10. Squuiid, Apr 29, 2017
    Last edited: Apr 29, 2017

    Squuiid macrumors 6502a

    Squuiid

    Joined:
    Oct 31, 2006
    #10
  11. haralds macrumors 6502

    haralds

    Joined:
    Jan 3, 2014
    Location:
    Silicon Valley, CA
    #11
    I like the idea of Nighshift (I use f.lux, but am not sure it does not interfere with System Sleep,) since it had to disable SIP anyway, I also gave CAT another try. It told be that Handoff was already enabled, but would you not know it that after two reboots the system is talking to my iPhone 7.
    Quirky...
     
  12. Squuiid macrumors 6502a

    Squuiid

    Joined:
    Oct 31, 2006
    #12
    You only need to disable SIP to apply these patches. Once applied you should reboot and re-enable SIP.
     
  13. haralds macrumors 6502

    haralds

    Joined:
    Jan 3, 2014
    Location:
    Silicon Valley, CA
    #13
    The altered KEXTs are not signed any longer. Can you really disable SIP?
     

Share This Page