Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

mad cow disease

macrumors regular
Original poster
Oct 12, 2005
101
6
I recently upgraded to Monterey and handoff/universal clipboard/Airdrop have stopped working in one direction, from my iOS devices --> Mac. What's most annoying is that it more or less works perfectly in the other direction, from Mac --> iPad Pro/iPhone XS Max. All of the obvious solutions have been tried. Everything is running the latest version of software. And yes, they're all devices compatible with handoff. Yes, they're all within range of each other. I have not ruled out possession by Bluetooth poltergeists, but a reliable detection method is still under investigation for that.

The only way I can get the handoff/clipboard/airdrop to work temporarily is to turn Bluetooth on and off on the Mac. This disconnects all of my peripherals, so I have to open my laptop clamshell and use the trackpad to turn it on Bluetooth again. It will then work...then stop working almost immediately after. To say this is colossally annoying is an understatement since I didn't realize how much I was using this feature until it stopped working (lol).

I've tried:
1) Signing off of iCloud on all devices, and then signing back in - didn't work
2) Restarting all devices - didn't work
3) Turning Bluetooth on and off on devices - didn't work
4) Turning handoff on and off on all devices - didn't work
5) Deleting Bluetooth plist file on Mac - didn't work

Out of ideas. Does the wise geniuses of this board have any other suggestions?
 

jeroenvip

macrumors member
May 13, 2017
99
128
I am on the same boat. Handoff between ipad, iphone and mac is not working. Nor is universal control between mac and ipad. The only thing that works is airdrop between devices. Of course i did the steps mentioned by the topic starter. Nothing worked.
 

PeteBurgh

macrumors 6502
Jun 25, 2014
280
620
I feel like Handoff/Continuity is the most Apple-y feature that ever did Apple. When it works, it is just awesome and seamless. A great expression of the benefits of an integrated ecosystem. But the seamlessness makes it virtually impossible to troubleshoot. Is it a hardware problem, some software or preferences thing, a cache that needs clearing? A network issue? No one can say - it just fails silently!

For me, it's worked perfectly for years. It was super buggy at launch with iOS 8, but at some point around 2018, stuff like Universal Clipboard started working for me, and has ever since.

I realise this is moaning, not practical help, but I'm not sure what to suggest! It sounds like you've been pretty comprehensive (you don't mention make sure that Handoff is switched on in system preferences, but I'm assuming that as you were so diligent with everything else!).

Could it be that your phones are on a different Wifi network? I have both a 5Ghz and a 2.4GHz with similar names, and sometimes have devices on separate ones causes problems. Just a long shot guess I'm afraid.
 

BigBlur

macrumors 6502a
Jul 9, 2021
630
686
It's interesting you say Handoff/Clipboard and AirDrop doesn't work. The first two are essentially the same feature. Universal Clipboard requires Handoff to be enabled. AirDrop doesn't, and works differently. If you're sure all three aren't working, it makes it seem like it could be a network issue.

You only mention Bluetooth, but do you also have Wi-Fi turned on? Apparently that is another requirement.

You could always try Reset Network Settings on your iOS devices...and if that doesn't work, then Reset All Settings.
 

donawalt

Contributor
Sep 10, 2015
1,101
533
Same issue for me - Universal Clipboard is not working between my Mac and either iPad or iPhone. the 2 iDevices work fine between each other. This just begun, after updates this week to iOS and/or MacOS.
 

Deedeekay

Cancelled
Aug 18, 2021
114
175
The only thing that has so far worked for me is navigating through user/Preferences and deleting the "com.apple.universalaccess.plist" file and restarting.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.