Handoff working on my iMac but not my MBA?

Discussion in 'OS X Yosemite (10.10)' started by houssein31, Oct 20, 2014.

  1. houssein31 macrumors regular

    Joined:
    Jul 16, 2013
    #1
    Ever since I downloaded Yosemite, handoff has only been working on my iMac and not my Air. Even though I turn on the handoff option in System Preferences>General and Wifi & bluetooth are on, my MBA is acting like handoff is turned off (not showing the icon on my iPhone nor on the MBA itself).

    Anyone know why?
    Thanks in Advance
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
  3. houssein31 thread starter macrumors regular

    Joined:
    Jul 16, 2013
    #3
    MacBook Air (13-inch, Mid 2013)
     
  4. jdag macrumors 6502a

    Joined:
    Jun 15, 2012
    #4
    There are many many posts about this, so I will submit the fix that worked for me in several threads in the hope that it helps people:

    I was struggling yesterday, and was having very mixed results ranging from handoff not working at all to it working on my iPhone only. I found an article offering a suggested fix, and it worked for me.

    It appears to me that the "missing link" is the FaceTime setup (this was the only article I found that referenced FaceTime settings).

    In my case, I had to sign into FaceTime using my AppleID (which I believe was set in the past, possibly disconnected at some point). Anyhow, it does make sense that this would be a potential gap in Handoff functioning, and it corrected my issue immediately.

    Good luck...this is clearly not an example of "it just works".




    The full article can be found at: http://www.ibtimes.co.uk/continuity-calling-handoff-not-working-ios-8-try-out-fix-1466213



    Step-1: Open the Settings app on your device running iOS 8

    Step-2: Click General

    Step-3: Click Handoff & Suggested Apps

    Step-4: Turn Handoff option Off and turn it On again

    Step-5: Tap General at the top of return to the previous menu

    Step-6: Tap Settings at the top of return to the previous menu

    Step-7: Tap FaceTime

    Step-8: Put the iPhone Cellular Calls option Off and then put it back On again

    Step-9: Once the action is completed, reboot the iPhone or the iPad
     

Share This Page