handy play/pause button for itunes, but affects VLC as well?

Discussion in 'MacBook' started by adamkesher234, Aug 26, 2009.

  1. adamkesher234 macrumors member

    Joined:
    Jun 25, 2009
    #1
    Hey guys,

    I love using the play/pause button on my macbook when used with itunes, it's handy as ****. But the problem is, that it affects VLC as well, and it plays a video and the audio interrupts whatever music I'm listening to (even when no video is opened but vlc is running, it'll open my last played video and play that alongside the music). I never had this problem with the old version of vlc, but ever since updating, vlc has now been wired to work with the friggen play/pause button.

    I tried looking in VLC preferences to see if it could be disabled but couldn't find anything regarding the mac play/pause keyboard button. Any ideas on how I can stop vlc from being affected by this key? And I'm not keen on the idea of going back to the older version unless it's my only option.

    Suggestions would be appreciated, thanks in advance.

    Cheers, Eugene
     
  2. matthewscott661 macrumors 6502

    matthewscott661

    Joined:
    Jun 27, 2009
    Location:
    Chicago
    #2
    I hate that, too. The buttons work for all media players that are open, not just the top one.

    One solution is to download sizzlingkeys, and set the option in keyboard preferences to use all f keys and standard function keys. It will only work for itunes though, and you will have to control all other players manually.
     
  3. adamkesher234 thread starter macrumors member

    Joined:
    Jun 25, 2009
    #3
    sweet, thanks for that. looks handy, ill check it out
     
  4. jgy3183 macrumors newbie

    Joined:
    Dec 1, 2010
    #4
    the new VLC for mac has options you can set to disable the media keys for VLC (and I tested it, and using the media keys on itunes did not activate VLC media player)
     
  5. Blondie :) macrumors 6502a

    Blondie :)

    Joined:
    May 12, 2010
    Location:
    Prescott, AZ
    #5
    The option to disable the media keys is indeed in the preferences pane. All you need to do is go VLC<preferences<interface and click disable "control playback with media keys" and you'll be good to go :)
     

Share This Page