Hard disk crash ... Tried migrating from Time Machine backup but problems

Discussion in 'OS X Mountain Lion (10.8)' started by ammusk, Aug 23, 2013.

  1. ammusk, Aug 23, 2013
    Last edited: Aug 23, 2013

    ammusk macrumors regular

    Oct 20, 2009
    My HDD (500GB) that came with my trusy 3 year old Macbook Pro crashed a few days ago.

    Luckily I have a Time Machine backup setup with Time Capsule.

    Bought a new SSD (240GB) for the MBP and tried restoring directly from the backup


    However this didn't work (because the SSD is smaller than my old HDD) and I ended up installing a fresh copy of Mountain Lion.

    After installation I successfully used migration assistant to transfer all the files and preferences from the Time Capsule.


    Everything good so far.

    Except I've been having permission errors and preferences not saving.

    Dropbox doesn't start up quoting a permanent error.

    Google Chrome extensions keep reinstalling.

    And a myriad of such issues.

    If it's a preferences problem how can I solve it?

    I've tried setting the Sharing and Permissions for the following (including their enclosed items)


    But no luck at all.

    And lots of files seemed to be locked as well. Including those inside ~/Library

    What's going on? How do I fix this? Please reply.
  2. ammusk thread starter macrumors regular

    Oct 20, 2009
    Solved this problem.

    Apparently lots of files were locked.

    Ran this from Terminal

    sudo chflags -R nouchg /*

    Everything seems great now.

Share This Page