Hard disk problems --- options?

Discussion in 'MacBook Pro' started by henrikk, Mar 14, 2012.

  1. henrikk macrumors newbie

    Joined:
    Mar 14, 2012
    #1
    I have a MacBook Pro 7,1 (Mid 2010). The internal hard disk is not functioning properly. System started acting strange and running slow and after some diagnostics it appears to me it was the hard disk... so I tried a reinstall. Nope --- it is not the hard disk. Have tested the drive on another MacBook Pro (works fine). I have tried different known working drives and even SSD's in the internal drive bay. All fail in the same same manner: I get an I/O error when trying to partition the drive and ready it for re-install. I do not think partitioning is the actual problem, but that is where the first time the "bad drive" symptom appears.

    Note, I can reinstall and boot the system using an SD card or external USB drive (partitions without issues and installs & runs OSX just fine). I simply cannot partition any drive I place in the internal drive bay. I can place a pre-partitioned & pre-installed drive in the bay, but as I said, the system runs erratic and slow on the internal drive.

    I have not tried a hard disk in the optical bay. I may try that in the future to see if I can make some use out of this MacBook Pro.

    I have no idea why this is happening.. maybe a bad sata controller? Bad cable? Bad circuit somewhere? I ask because I want to know if this is a known issue or problem other users have seen.

    So, has anyone seen this problem before?

    Thanks,
    - Henrik
     
  2. benmandv macrumors newbie

    Joined:
    Aug 25, 2010
    #2
    Hi there

    Sounds like a bad SATA cable to me.
    My macbook (mid 2009) had this problem last year and its just happened again. It seems Apple has a bad batch of SATA cables in circulation!!
    It will work if you plug the drive into the Optical bay as did mine.
    Take it to an Apple store and let them replace the cable. That should sort it.

    Happened on this thread too: http://forums.macrumors.com/showthread.php?t=1031577&highlight=internal+sata+cable

    I think this is a bigger problem than Apple make out...

    Cheers
    Ben
    www.holika.org
     

Share This Page