Hard drive can not be partitioned after shutdown during prior partition

Discussion in 'Windows, Linux & Others on the Mac' started by Tim Hargreaves, Jan 8, 2014.

  1. Tim Hargreaves macrumors newbie

    Joined:
    Jan 8, 2014
    #1
    Whilst partitioning my Mac Hard Drive to install Windows 7 via the bootcamp assistant, my computer - oblivious to me until too late - ran out of charge. When I turned it back on, as expected, the was no completed partition and bootcamp assistant still gave me the option to partition my hard drive. When I tried to partition my drive however, I get an error stating that:

    I assume this is because I already have a semi-complete partition existing.

    More reason to think this is apparent when I ran the disk utility application and saw that despite there only being one drive (Macintosh HD) This only took up 450Gb (Out of 500Gb) - the rest blank. Since my partition was 50Gb, you would assume that that is what is taking up that space and disabling a new partition.

    Any idea of how I can fix this?
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Do you have a clone or a bootable USB stick or DVD, to Check/Repair the whole internal drive via its Disk Utility ?
     
  3. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #3
    Or try the recovery partition disk utility as the boot drive will be unmounted. You should be able to resize it back in there.
     

Share This Page