Hard Drive Compatibility Issue?

Discussion in 'Mac Pro' started by Adros, Apr 23, 2009.

  1. Adros macrumors member

    Apr 3, 2009
    So my new Mac Pro just arrived (yay!) and one of the first things I tried to do was slip in the hard drive from my older Power Mac g5 (which had a sudden and tragic death a few weeks ago) to see if that was what caused it. So I slipped it in (Wow at how easy that is) and it didn't show up. My first thought was, "Ah hah! YOU are the reason my beloved kamikaze_carebear is dead." Then I checked disk utility, and the hard drive shows up just dandy, same with system profiler...

    So now I am wondering at this point if its a compatibility issue with the hard drive and the new computer, or if the hard drive is screwed up somehow but magically the desktop knows what it is, (I know I know, unlikely but I have experienced stranger mysteries on the computer) or if its something really simple, like both hard drives being named Macintosh HD or something... Anyhow, here is the drive info (also a newegg link if thats quicker for some of you):

    Maxtor 6B250S0

    Capacity: 233.76 GB
    Model: Maxtor 6B250S0
    Revision: BANC1E50
    Serial Number: B621SBKH
    Native Command Queuing: Yes
    Queue Depth: 32
    Removable Media: No
    Detachable Drive: No
    BSD Name: disk1
    Bay Name: "Bay 2"
    Mac OS 9 Drivers: No
    Partition Map Type: APM (Apple Partition Map)
    S.M.A.R.T. status: Verified
    Macintosh HD:
    Capacity: 233.64 GB
    Writable: Yes
    File System: Journaled HFS+
    BSD Name: disk1s3
    Mount Point:

    Only two reasons I can really think of is its SATA 1.5 instead of 3, (no idea if that matters for this) and that I took it from a PowerMac running 10.4... Anyhow thanks for reading all this and any responses!

    No idea if this is relevant, but running disk utility Verify Disk yields this error:
    Invalid sibling link
    Volume check failed.
    Error: Filesystem verify or repair failed.
  2. nanofrog macrumors G4

    May 6, 2008
    The 1.5 or 3.0Gb/s throughput of the SATA interface won't matter. It would still work. ;)

    The error listed on the bottom of your post is the reason. Remap the drive, and see if that will fix it. DATA will be lost, but it might salvage the drive. Otherwise, it's toast.
  3. Adros thread starter macrumors member

    Apr 3, 2009
    Honestly the only real value of this drive is the data that is already on it, so I am really looking for a way to save it!

    Also when you say "Remap the drive," what do you mean? Reformat, or something entirely different?
  4. nanofrog macrumors G4

    May 6, 2008
    Remap is a low level format. It routes around the bad blocks/sectors on the drive. It may be followed by an upper level format (wipes data, whether good or corrupted), which is the file system used by the OS.

    There might be a couple of software packages that would help. (Allow a remap without losing data, or at least all of it). ;) Data Rescue II or File Salvage come to mind for OS X. :)

    Otherwise, the drive is toast. Even if it's salvaged, get another drive, and backup the data. Then toss the Maxtor, as these issues get progressive, and fast. This is why backup is needed, not really an option. ;) :D :p
  5. Adros thread starter macrumors member

    Apr 3, 2009
    Thanks for your help and recommendations nanofrog. Fortunately I had backed up most of the data on the drive, so it is definitely is not worth a $90 piece of software to get a few files. Guess it was just that drives time.
  6. nanofrog macrumors G4

    May 6, 2008
    Though useful, it's price is about the cost of a new drive, depending on capacity. :eek: :rolleyes:

    At least you managed to save most of it. :)

    There's still no real alternative for a backup solution. ;)

Share This Page