Hard drive failing?

Discussion in 'Mac Basics and Help' started by osprey76, Apr 19, 2015.

  1. osprey76 macrumors 6502

    Joined:
    May 3, 2004
    Location:
    Oklahoma City, OK
    #1
    I think I might have a hard drive failing and I would like to get some secondary advice.

    Symptom 1: I am trying to move a large iPhoto library (475 GB) from my iMac with a 3 TB Fusion Drive to a 1 TB external Firewire HD. When the transfer starts, the projected time is about 25 minutes. At about 1.56 GB transferred, the speed drops dramatically and the expected time increases exponentially from there. I have not let the transfer more than a couple of hours and this trend never seems to improve.

    Symptom 2: Time Machine backups are failing at times, lately is more often than not. I thought this might be something to do with 10.10.3, but now I am less sure.

    Symptom 3: This Mac has often had some sluggish/unresponsive episodes where it required a reboot or a hard shut off. There were intermittent beach balls of death while the iPhoto transfer was underway.

    Things I have tried/looked at so far: I recently got TechTool Pro 8 and ran the test suite. It reports SMART and file structure as being okay, but a surface scan shows 80 bad blocks out of 5 billion on the 3 TB internal hard drive. TTP also did not report any files residing on these blocks. The internal SSD part of the Fusion Drive checked out fine. The external drive passed a surface scan and is a freshly formatted drive. I installed an eDrive on the Firewire HD and booted from there and attempted the same iPhoto library copy with the same results. It has been a month or two, but I have run things like Cocktail in the past to try and help with the computers performance with some small improvement.

    Are there any other recommendations for what to check next?

    The computer is:
    iMac (27", Late 2012), 3.4 GHz i7, 24 GB RAM, 3 TB Fusion Drive

    Thank you in advance!
     
  2. corvustheraven macrumors newbie

    corvustheraven

    Joined:
    Apr 22, 2015
    Location:
    Maryland, USA
    #2
    I have had a similar problem where there is a slow down of file transfer speeds, especially when transferring files in a Virtualbox guest. What seemed to be the problem was that there was not enough RAM to cache the files being transferred, and was able to get around it by moving less files at a time.

    It may be that the large amount (475GB) that you are attempting to transfer is overloading the RAM, and moving some of the processes to SWAP memory, which can be slower, since it is reading/writing information to the drive instead of the RAM. If you move less at a time, it should go quicker, as it is not trying to cache such a large amount of information at once.
     
  3. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #3
    Could it be possible that -- during the transfer -- you are encountering one or more "bad files" (i.e. bad blocks, etc.) that bring the copying process to a grinding halt?

    Suggestion:
    Download CarbonCopyCloner and give it a try at copying the files.

    I believe CCC (during the progress of the copying) will "pass over" bad files and go on with the job, copying the good files and "leaving the bad ones be".

    I believe it will also give you a report at the conclusion of the process listing which files couldn't be copied.

    It's worth a try to do it this way. If it works for you, fine.
    If it doesn't solve the problem, just try something else.

    CCC is FREE to download (fully functional version) and it's FREE to use for 30 days.

    Another thought:
    Have you given consideration to trying to do this copy in a more "piecemeal" operation?
    That is to say, choosing to copy a "smaller chunk" of say, 10-20gb, then another chunk, then another?
    You'll have to "keep notes" as to what's copied and what's not, but it might work and help you to isolate whatever it is that is slowing you down...
     
  4. bookwormsy macrumors 6502

    Joined:
    Jul 7, 2010
    #4
    Have you tried going into Disk Utility and Repairing the disk and Verifying Disk Permissions?
     
  5. osprey76 thread starter macrumors 6502

    Joined:
    May 3, 2004
    Location:
    Oklahoma City, OK
    #5
    Update

    Thank you for the suggestions. Here is what I have found, so far.

    The file in question is the iPhoto library, which I cannot break up into smaller chunks. The copy job does not seem to be RAM limited, but does appear to be stopping due to a corrupted file. The iPhoto library is an archive or special folder. You can right-click on it and "Open package contents". This allows you to see inside (earlier iPhoto library were in fact normal folders) and allows you to access the contents. Since my library generally seems corrupted, I successfully copied out the Master folder with all of the original pictures. So, that most important part is safe. The next step is to experiment with some Time Machine backups. Notably, I get similar errors trying to copy the new Photos library that was successfully migrated from iPhoto. Photos was syncing okay to iCloud for a while, but seems to be failing now. I do not know if this is related to the same issue or not. Losing my photos is highly undesirable, so I feel better with a known good copy made even if the iPhoto metadata is lost (faces, groups, etc.). I have another drive coming in to make another series of copies before I get serious about tinkering (breaking) things further.

    I did get CCC and started a clone onto my Drobo 5N. I am awaiting the other drive before going too far down this road. I am starting to see the weakness in using just Time Machine and possibly the Drobo. Some as simple as some bare drives and some CCC versioning would be really useful in this scenario. I will check to see how CCC handles corrupt files. It looked to be copying individual files inside of the iPhoto or Photos libraries during the clone. If so, it is possible that CCC will simply skip the one bad file in the entire archive. That would be terrifically handy if it does. I will report back here.

    I have had stuttering performance off and on, with no clear reason as to why. At times, you get a beachball for 1-5 seconds when switching applications. This is with no plenty of free RAM via Activity Monitor. I got TechTool Pro 8 recently and ran the test series. Nothing came up as unusual except some bad blocks on the 3 TB hard drive part of the Fusion Drive group (The SSD portion checked out fine). I believe the first test showed 51 blocks out of something like 5 billion were bad. I know more recent tests seem to be stable at 80 blocks. TTP did not report any files located on the bad blocks. I am concerned about that, but do not think it is related to the stuttering. I ran the Apple Diagnotic Test and it reported a 4MEM error. I tracked this down to be a RAM issue with a few references to Corsair memory not working well with Macs. I added at Corsair 16 GB kit to the original 8 GB present not long after purchasing the computer. So, I pulled those memory modules, reran the Diagnostic which showed clear (though, interestingly the test only showed the error 2 out of 3 tests with all modules in place), and found the same stuttering behavior as before. As I write this, an obvious test to do would be to run the Diagnostic test a few more times.

    I did repair disk permissions and both Disk Utility and TTP report the Macintosh HD volume as appearing okay. I found another utility on the Apple forums that runs a check routine (I can't remember the name, but it starts with an E). This reported 24 errors with the main volume.

    Unfortunately, I was under a time crunch as I was heading back to work yesterday. I can remotely access the Mac, though. Any thoughts on all of this? With a pair of backups, I will feel comfortable to tinker more and/or take it into Apple. I think I have a hardware problem somewhere, but it could be software and repaired with a restore (mostly, the iPhoto issue is another problem).

    Thanks everyone!
     
  6. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #6
    OP wrote above:
    [[ The file in question is the iPhoto library, which I cannot break up into smaller chunks. ]]

    You most certainly CAN break it into smaller chunks.

    Right-click on the iPhoto Library icon, and you will see an option to "show package contents".

    You can now view -- and copy -- the various items inside the iPhoto library.

    IMPORTANT!
    If you do try this method, it is ESSENTIAL that you replicate the folder/file structure in your new iPhoto library file.

    It might help to create a "new" (i.e., empty) iPhoto library on another drive, then copy over items into that library.

    ONE OTHER THOUGHT:
    If I was in your position, I would have a blank "target" drive ready and online.
    I would then launch CarbonCopyCloner.
    I would then UNCHECK EVERYTHING in CCC, with the EXCEPTION of the iPhoto library package file.
    I would then let CCC attempt to copy the iPhoto library to the target drive.
    ...And see how that goes.
     
  7. osprey76, Apr 24, 2015
    Last edited: Apr 25, 2015

    osprey76 thread starter macrumors 6502

    Joined:
    May 3, 2004
    Location:
    Oklahoma City, OK
    #7
    Fishrrman,

    Good points. My first CCC run just finished where I attempted to clone to a Drobo sparseimage. CCC reported completion with errors and reports which things have errors on them. This included a handful of photos in the Photos/iPhoto libraries and a few other disparate files. So, it appears I have a good copy of all of the library other than a few (<10) pictures. I suspect these various unreadable files are the reason Time Machine is failing. I also wonder if the hard drive is indeed failing or suffered an error fairly recently since the problem files are not just related to iPhoto/Photos. Time Machine last ran successfully on April 16.

    I now have 3 backups of my photo library, 2 of which I feel confident in. CCC to Drobo, photo master files to independent hard drive (the drive is too small for a CCC clone), and last successful Time Machine backup to Drobo. Once I get the new drive in, I will run another CCC clone and then I can get serious about figuring out what the root problem is in the system.

    Thank you for the reminder on Carbon Copy Cloner. I have used it in the past, but did not think of immediately in this case. It has only gotten better with time.

    I am still befuddled by mixed results from various programs on the health of the hard drive system (a Fusion Drive). Some report all is well, others report errors. It seems like a clean wipe is the way to go and then reimporting select things, but reinstalling most software to avoid corrupt background files. If the performance is similar after this exercise, then I feel like it points squarely to a hardware issue. I may look at taking in to Apple at that point. I was hesitant before without having a very solid backup in hand.
     

Share This Page