Hard drive help

Discussion in 'MacBook Pro' started by epdaddy, Jan 2, 2011.

  1. epdaddy macrumors newbie

    Joined:
    Jan 2, 2011
    #1
    Hello everyone,
    I need some help.
    I have just replaced the hard drive in my 2009 macbook pro.
    I try to boot up the computer with the leopard instal disk in with no luck.
    I have also done it holding down the c key but it will just show the blue apple screen with the wheel spinning for about 3-4 minutes than go to a black screen.
    I am not a computer wiz and need help.
    Thanks
    EPdaddy
     
  2. peapody macrumors 68040

    peapody

    Joined:
    Oct 7, 2007
    Location:
    baltimore, md
    #2
    Did you hold down the option key? That will let you boot into your install disk and do a clean install.
     
  3. epdaddy thread starter macrumors newbie

    Joined:
    Jan 2, 2011
    #3
    Thanks

    Thanks. Now a picture of the install disk shows up with an arrow under it.
    I press enter and the wheel begins to spin then goes back again.
     
  4. oakie macrumors 6502

    oakie

    Joined:
    Oct 16, 2008
    Location:
    seattle
    #4
    sounds like a hardware issue. might want to have your optical drive looked at.
     
  5. epdaddy thread starter macrumors newbie

    Joined:
    Jan 2, 2011
    #5
    Still having trouble.

    Ok I tried to boot up with an external Cd drive with no luck.
    Does that mean that it is something other than the optic drive?
    Could it be the motherboard? If it is...is it replaceable?
    Is it expensive or is it shot.
    Sorry about all the questions. As I stated earlier... Im not the quickest when it comes to this stuff.
    Epdaddy
     
  6. NickZac macrumors 68000

    NickZac

    Joined:
    Dec 11, 2010
    #6
    How long do you let the blank screen go? It can take quite a while for the disk to load (mine takes about 4 minutes). Do you have Applecare? Did you replace the hard drive simply to upgrade or because something was wrong with the original one? What HD are you using?
     
  7. epdaddy thread starter macrumors newbie

    Joined:
    Jan 2, 2011
    #7
    Help

    I put in a new HD (sata) because I thought that was the issue.
    It stays black forever.......
    EPDaddy
     
  8. NickZac macrumors 68000

    NickZac

    Joined:
    Dec 11, 2010
    #8
    So you thought your HDD was failing and replaced it, correct?

    What brand is it? SATA is (simplified) a connection port on virtually all newer computers.
     
  9. epdaddy thread starter macrumors newbie

    Joined:
    Jan 2, 2011
  10. epdaddy thread starter macrumors newbie

    Joined:
    Jan 2, 2011
  11. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #11
    Try this.

    http://support.apple.com/kb/HT3964

    or maybe this

    http://docs.info.apple.com/article.html?path=Mac/10.6/en/26871.html

    Cheers,
     
  12. NickZac macrumors 68000

    NickZac

    Joined:
    Dec 11, 2010
    #12
    Have you tried booting the computer with the original hard drive?
     
  13. epdaddy thread starter macrumors newbie

    Joined:
    Jan 2, 2011
    #13
    It Worked!??

    It worked! But now the track pad won't work.
    It will let me move the curser around but not click or tap on anything.
    The track pad was acting goofy before I re-placed HD.
     
  14. panzer06, Jan 8, 2011
    Last edited: Jan 8, 2011

    panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #14
    How did you fix it ...and have you spilled anything on the keyboard or trackpad? I assume an external mouse works fine. If liquid damage and it still doesn't work it may need to go in for repairs. As you've stated replacing the hard drive would not cause a trackpad to fail.

    Cheers,
     
  15. epdaddy thread starter macrumors newbie

    Joined:
    Jan 2, 2011
    #15
    no spill

    Your second link fixed it!!
    No I have had no spills at all.
     

Share This Page