Hard Drive Help

catfish743

macrumors 6502
Original poster
Sep 12, 2007
305
1
Kentucky
So I have a Lenovo 80 GB HDD and I've plugged it into my Mac before and it has mounted. When it did that, I got everything off of the HDD and all was well. Now, when I try mount it again it says it is unmountable and then when I try to erase it my computer freezes. I'm currently on a 24 inch 2.4 GHz 3.0 GB mid 2007 iMac running Leopard.
Any suggestions..,please???

(P.s. An idea that I had if anyone could fix it, although they might be unable to explain how, could use screen sharing in leopard...just a thought.)

Thanks for your help.
 

admiraldennis

macrumors regular
Aug 19, 2002
239
0
Boston, MA
Can you elaborate a bit?

Is this drive connected to your Mac via IDE, SATA, or USB/FireWire?

Define 'freezing'. What does your computer do exactly when you try to format the drive? Have you tried re-partitioning the entire disk instead of just formatting a volume?
 

catfish743

macrumors 6502
Original poster
Sep 12, 2007
305
1
Kentucky
It is connected via USB. Freezing involves the beach ball of death with the Disk Ultility. I've left it on trying to work for a day...and it just was hung the entire time. I haven't tried repartioning...I'm going to try that now.
 

byakuya

macrumors 6502a
Jul 26, 2007
542
0
by repartitioning do you mean you formatted the HD completely?
if yes, the HD just might be defective...
 

catfish743

macrumors 6502
Original poster
Sep 12, 2007
305
1
Kentucky
I mean it wont do anything. I can't erase it, I can't partion it. It says partion map is being created and then it says that for hours and days at a time. It just wont work. I'm not sure what to do. Disk Utility just freezes.
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.