Hard drive issues

Discussion in 'macOS' started by jsadwith, Apr 10, 2008.

  1. jsadwith macrumors newbie

    Joined:
    Dec 28, 2007
    #1
    My MB at work got the pinwheel and crashed 4 times in a row today. I ran the Repair Disk in Disk Utility from the Leopard CD, and it failed because of an "Invalid node structure". The same thing happens when I run fsck in single-user mode. Now (later in the day), if I restart the computer, it goes past the Apple screen and turns off. Disk Utility via CD says 'Macintosh HD' is not mounted.

    The strange thing: if I go into single-user mode, all of my files are there and Macintosh HD is intact (Disk Utility still says 'Invalid node structure' in single-user mode).

    Similarly, if I hook up the laptop to my personal MBP via FireWire (to back up my files), I can successfully place it into Target Disk Mode, but the drive never appears on the host computer.

    Note: any searches into the "Invalid node structure" tell me to purchase DiskWarrior, but the computer is under AppleCare, and I'd much rather just send it in to them. The only problem is that if I do, I will most likely lose all of my data, so I still need to find a way to back it up.

    Any thoughts/ideas/comments? Anything would be much appreciated.
     
  2. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #2
    Definitely back up the drive. Time Machine is the best way to go, if you can get it to work. If you have another Mac, you can start your bad one in Target Mode (hold down Command-T at power on) and connect to me other MAc with Firewire cable, and backup your stuff.

    Then do an Erase & Install of OS X. This will format the drive.

    Disk Utility (or fsck) are not able to recover all kinds of hard drive corruption. Maybe Disk Warrior could do it, but is it worth it?

    If you think it is a defective hard drive, then you will need to send it in to Apple to have the drive replaced. But you still need to make the backup.
     
  3. jsadwith thread starter macrumors newbie

    Joined:
    Dec 28, 2007
    #3
    Already tried Target Disk Mode. Never showed up on the MBP - even after restarting the host computer (recommended by Apple if the drive doesn't initially show up).

    Any other ideas?
     

Share This Page