Hard drive not mounting - disk0s2: media is not present.

Discussion in 'Mac Basics and Help' started by kierand, May 21, 2012.

  1. kierand, May 21, 2012
    Last edited by a moderator: May 21, 2012

    kierand macrumors newbie

    Joined:
    May 21, 2012
    #1
    My Macbook Pro was running absolutely fine until I tried transferring a 10GB file from an external disk drive. It froze 3 times and each time I had to switch the power off on my machine to restart (it's at this point I gave up trying to transfer but I wish I'd given up earlier!)

    Shortly after my machine started freezing, and after this happening about 3 times my machine won't get past the grey apple logo/spinning wheel.

    I've tried booting from my Snow Leopard CD and Disk Utility found no problems, so I decided to try reinstalling Snow Leopard. It starts installing and when it gets to about 20% it says it doesn't have enough memory, then shows what it's trying to install on and it's the below - the hard drive seems to have vanished after showing before...screengrab attached.

    Any ideas? Any help much appreciated.

    I can hear the disk spinning as it tries to boot but it's still just sitting on the grey apple logo screen...

    [​IMG]
     
  2. kpgh554 macrumors regular

    kpgh554

    Joined:
    Dec 29, 2011
    Location:
    iver england
    #2
    try repartitioning hdd using cd disc's utility as single partition in hfs extended then retry installing snow leopard
     

Share This Page