Hard Drive Not Showing up After Restart

Discussion in 'Mac Basics and Help' started by indy42, Dec 5, 2009.

  1. indy42 macrumors newbie

    Joined:
    Jul 13, 2008
    #1
    I'll try and put all the details here:

    I was capturing some footage on Final Cut Pro (the capture scratch runs to my 320 gb Maxtor External Firewire hard drive).

    Just after capturing and saving, FCP went to the balloon ball of death and wasn't responding. I tried to open Finder to make sure the captured video was saved, but Finder went balloon ball of death too, and stopped responding. (where when you right click the icon it automatically says "Force Quit")


    So I relaunched Finder. I tried to force quit FCP, which didn't quite seem to work, and the Finder didn't come back either. So I decided to just shut down the entire computer manually (holding the power button for a few seconds). Then I restarted.

    So now my hard drive won't show up again. I've toggled the power button, taken the firewire in and out, unplugging it, etc. I've tried it on another Mac in the house - it worked. It just won't work on the one I need it to.

    Please Help!
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
  3. indy42 thread starter macrumors newbie

    Joined:
    Jul 13, 2008
    #3
    I'll try an SMC reset, thanks.

    I've looked at the disk utility, but it doesn't show up in there, either.
     

Share This Page