Hard Drive Problem

Discussion in 'Macintosh Computers' started by derajfast, Jun 18, 2005.

  1. derajfast macrumors 6502a

    Mar 24, 2004
    I just tried using my lacie 120 external HD with my 15inch PB, but the HD wont mount on my desktop...the computer recognizes it and i went in to disk utility and it said "Verifying volume “LaCie 120 GB”
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Invalid sibling link
    The volume LaCie 120 GB needs to be repaired.

    Error: The underlying task reported failure on exit

    1 HFS volume checked
    Volume needs repair

    I then tried repairing it, but it did the same thing. What could be the problem and what can i do?
  2. derajfast thread starter macrumors 6502a

    Mar 24, 2004
    also, the hard drive works on my PC which has no problems detecting it....imagine, a pc doing sometiong my mac cant, what a day......
  3. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    The problem you have is not with the hardware, it is with the organization of the data in your logical HFS+ volume.

    It's not surprising your PC can see the drive. If you have a FAT-32 or a NTFS volume on the drive, the PC is looking at different data with a different catalog. I don't believe the PC can see the contents of a HFS+ volume at all unless you have 3rd party software like MacOpener.

    Basically, the catalog that contains the locations of all of your Mac files on the drive is borked, and too badly for Disk Utility to fix it. You can try one of the major-league disk repair programs like DiskWarrior or TechTool Pro. DiskWarrior in particular specializes in rebuilding damaged catalogs. Be prepared for it to take a LONG time to run the repair - don't interrupt it. Set your EnergySaver to "Never Sleep" before starting. On a Powerbook, remember to plug it into the wall.
  4. derajfast thread starter macrumors 6502a

    Mar 24, 2004
    are these programs free? the thing is though ive used it with my powerbook in the past, so i dont know hwy all of a sudden it did this. i cant remember if ive used it since i got tiger or not. could that be the problem?

Share This Page