hard drive problem

Discussion in 'Mac Basics and Help' started by rorymilli, Sep 13, 2006.

  1. rorymilli macrumors member

    May 25, 2006
    Hello There, I have just installed a bigger hard drive in my iMac G3 CRT (it is a seagate barracuda 60Gb ATA). I fitted it, then used my factory grey disk to 'initialize' (writing zeros) then clicked on the OS software restore. It all seemed to go well until it was calculating the checksum at the end of the process when it said it had a problem. I ran disk first aid from the utilities on the grey disk. I got this report

    Following problem
    Invalid header 0,9026
    Invalid header 1025, 9026

    I booted from my Techtool disk and ran a ceck on the hard drive. I got the following report:

    Checking disk Macintosh HD
    Checking 'OS Standard' volume structures
    Problem Master Directory Block needs minor repair, 1,0
    Checking wrapper System file
    Repairing the disk
    Checking 'Mac OS Extended' volume structures
    Problem Invalid BTree node size, 3,0
    Test done, Problems were found, but Disk First Aid cannot repair them

    Is this something that can be fixed or is my first journey into the insides of my iMac a failure.

  2. rorymilli thread starter macrumors member

    May 25, 2006
    stupid error

    Hello Everyone. I made a really stupid mistake. I was trying to 'restore' with the wrong disk. I have two iMac G3 CRTs one is an Indigo that came with OS 9.0.4 and one a Flower Power that was shipped with OS 9.1. I tried to install OS 9.1 on the machine that came with 9.0.4. It just shows that all iMacs are not the same! It is working well now. :eek:

Share This Page