Hard drive replacement Late 08 MacBook Pro HUGE PROBLEMS

Discussion in 'MacBook Pro' started by DYER, Oct 10, 2011.

  1. DYER macrumors 6502

    Joined:
    Oct 4, 2008
    Location:
    London, UK
    #1
    OK guys, I am officially at the end of my tether so if this seems like a rant I apologise but I really really need some help!

    I have a Late 08 MacBook Pro - 2.8Ghz. Which has been upgraded to 8GB of RAM.

    The hard drive it came with was a 7200 RPM 320GB.

    I need a larger hard drive. Files have got larger from my cameras and now some video too so I bought a 7200RPM 750GB WD Scorpio Black.
    Installed the drive put Lion on it and every 30 seconds it froze.
    Thinking the hard drive was a dud I arranged a replacement drive with WD but the exact same issues occurred with the second drive.
    Now if I plugged that same drive into my Hard drive dock and booted from the dock - not a problem Lion ran fine except obviously it was quite slow as a FireWire connection just isn't as fast as the one in the laptop also it is a little unpractical to have a laptop that needs a drive to be outside of the laptop to run.

    So thinking there is some huge compatibility issue with WD drives and Lion or my MBP (WD tech support mumbled something about Lion not working with their new drives)
    I went out and Bought a Seagate 750GB 7200 RPM Momentus drive. This was from a Mac specialist that claimed it would work fine in my MBP.

    Well it doesn't and this is where it all gets a bit weird.

    The drive worked for a few days just fine inside the laptop it was quick and did what I wanted to do but then 'crashed' when i restarted. I got it working again and then had to restart and this time it firmly refused to work.

    I re installed Lion and started up. After the initial chime the drive RANDOMLY showed the Apple Logo (normal boot up) then the folder with the question mark and then the broken signs (the circle with the line through it) and it cycled through them randomly for a few seconds (showing each for half a second) and then either stayed on the question mark or 'booted'.
    But when it 'booted' it did not as it took me to the Lion welcome screen which you get when you first install Lion. Which was even more strange.
    Also

    Now I tried repairing disk in disk utilities, I tried repairing permissions Nothing has worked so far.

    BUT again if I put the HDD into the dock it boots just fine.
    Someone please help me. What on earth am I doing wrong???
    I have now spent £200 on HDD's and NOTHING has worked. It is confusing the hell out of me. HOW can these Hard drives not work.

    I also received another error once or twice right after the Apple Chime.
    'Unable to find driver for this platform "acpi" - i can get the full error message if you guys think it is important.

    Please help me guys. I am literally giving up.
     
  2. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
    #2
    My best guess is that the hard drive you bought has an SMS built in. Apple's motherboards have SMS onboard. So, 2 SMS systems are battling it out and interfering with each other. You need a hard drive that does not have an SMS system on it.
     
  3. Naimfan macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
    #3
    You might take it in to an Apple store or specialist and have them test it. Since you've tried different drives, and they all work OUTSIDE the MBP, my thought is that your hard drive cable is bad but that it only shows up intermittently.
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    Since you said you reinstall Lion, I would say it's not a software issue. Then you've tried different HDDs, so it'll most likely be a motherboard issue.
     
  5. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK
    #5
    My guess is you're not seating the SATA cable properly.
     
  6. pancakedrawer macrumors regular

    Joined:
    Dec 13, 2010
    Location:
    Melbourne
    #6
    I'd completely wipe the drive and double check the connections. Then install the drive internally and do a clean install of snow leopard, just in case it is a lion problem (snow leopard should be solid). This would remove all possible software issues.
     
  7. samh macrumors 6502

    Joined:
    Oct 29, 2009
    #7
    I had similar issues with a Mid-'09 MBP. They replaced the Hard Drive Bracket. Didn't fix the problem with my Scorpio Black.

    Turns out an EFI update from 2009 enabled 3.0 Gbps SATA drives, but lots of people have had trouble when installing a 3.0 drive. There are two ways to fix, if this is the problem (can't be sure if it affected 2008 model):

    1 - Downgrade the firmware (not exactly easy)
    2 - Check to see if your Seagate drive has the option to force it into 1.5 Gbps mode. You may have to buy a mini jumper to set it.
     
  8. DYER thread starter macrumors 6502

    Joined:
    Oct 4, 2008
    Location:
    London, UK
    #8
    Thanks for the help everyone.
    I have to admit I once again turned to Apple for help and they tried a fresh install to no avail and are no replacing a hard drive cable in my mac.
    I will use some of your solutions if that doesn't fix it but encouragingly the guy I spoke to was adamant they would get it working.
    The genius took about 800 words of notes so hopefully the techie can get it running when I bring it in tomorrow.
    Will keep you updated on a solution.

    I do wonder whether it has something to do with the 3.0 connection will look into limiting it to 1.5...
     
  9. john10 macrumors newbie

    Joined:
    Mar 27, 2012
    #9
    Any resolution?

    Dyer, did you ever figure out a solution? I have the identical setup (late 2008 MBP, 8 GB, 750 GB WD Scorpio Black) and the identical problem (random 30 second beachballs, ranging from every 15 minutes, down to every minute or so). It seems to develop some weeks or months after wiping and reformatting a drive, which I've been through a couple of times with this machine. I had the same thing develop with an earlier replacement drive on the same machine (Seagate Momentus 500 GB).

    The only consistent thing I've ever noticed is this or a similar entry in the system log almost invariably accompanies the freeze (I wiped the cache id, because I don't know if it means anything):

    3/27/12 11:12:27.770 PM warmd: [_bootcachectl_playlist_dir_for_user:1887] Assertion failed: ((*__error()) == 2): stat'ing /var/db/BootCaches/XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX failed: 13 Permission denied

    and yes like you I've done all the obvious things and all the not-so-obvious things and even all the completely arcane things numerous times in various orders and combinations with no joy.

    Recently I ran an extended (2 hour) S.M.A.R.T. analytic on the drive and all was 100% okay, btw so I kinda suspect it's not hardware problem or if it is, it's a subtle interaction between hard and software.

    Interestingly, after booting in safe mode, when I've tried it, has so far resulted in beachball-free but crippled experience, so it might well be an extension(s) issue, maybe a second-or-higher-order interaction among extension and hardware. But even if so, lengthy trial and error has so far not disclosed what…

    Very sad for me (and you). But I see many references on many forums to folks with similar issues after exchanging/upgrading drives.
     

Share This Page