Hard drive space decreasing automatically

Discussion in 'macOS' started by Matt Gnarly, Dec 6, 2009.

  1. Matt Gnarly macrumors member

    Joined:
    Aug 14, 2008
    #1
    Hey Macrumors, got a quick question, for some reason when I start my Macbook I have ~80gb of free space on my hard drive, this slowly starts to decrease upon using the computer until I have ~300mb of space left. I'm not downloading anything during this process, just browsing on the internet. I've attached a start up screenshot and one after a half hour, it shows that the hard drive space is being used by a private folder. I figured I would see if maybe someone knows what is going on here before reinstalling Snow Leopard.
    Thanks
     

    Attached Files:

  2. Matt Gnarly thread starter macrumors member

    Joined:
    Aug 14, 2008
    #2
    I've traced the problem to mdworker32, not sure what its doing but it's creating numerous files, after restarting the computer the harddrive is full but after emptying the trash (which was empty upon shutdown) I have my 80 free gb, and then it starts filling up again.
     
  3. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #3
    mdworker is the process that archives the index for Spotlight search. It's triggered when you have a 32-bit .mdimporter in either /Library/Spotlight/ or ~/Library/Spotlight/.

    I've found that some people have issues with it when it indexes Office 2008 files. You might want to check those above folders I mentioned and see if there's something called "Microsoft Office.mdimporter" in there. Delete it.
     
  4. Matt Gnarly thread starter macrumors member

    Joined:
    Aug 14, 2008
    #4
    The only thing I found in library/spotlight was notebook.mdimporter, I deleted it and the result is thus far the same. I will try rebooting and see if it has made any difference. Also, what is ~library/spotlight? How would I get to it?
    Thanks for the help
     
  5. Matt Gnarly thread starter macrumors member

    Joined:
    Aug 14, 2008
    #5
    I've deleted all importer files from both spotlight libraries, no change at all.
     
  6. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #6
    There are two Spotlight folders, one located in:
    Macintosh HD/Library/Spotiight

    And the other in:
    Macintosh HD/Users/youruseraccount/Library/Spotlight

    Check both of those folders and restart the computer if you find the Microsoft Office one. At least one Spotlight plugin has to be causing the problem. Check both folders and see if there's anything in them that looks specious. Don't delete everything though — you might want to keep some of those plug-ins.

    If neither works, then I guess just kill the process via Activity Monitor. Don't think that'll be a permanent fix though.
     
  7. Matt Gnarly thread starter macrumors member

    Joined:
    Aug 14, 2008
    #7
    Thanks for all the help Ziggy, I removed all the files from both those folders you mentioned and upon restart the problem as stopped, I'm going to now restore the plug-ins one at a time until I find the problem plugin.
    Update: looks like it was not the microsoft office plugin
     
  8. chaosrxn macrumors newbie

    Joined:
    Feb 1, 2010
    #8
    Torrenting?

    I had the exact same problem and fixed it with a little folder tunneling. Are you downloading any torrents on vuze? I found a HUGE torrent file hidden away on my harddrive. What happened was I downloaded the torrent/magnet from the vuze client directly and something must have went wrong and it made a 31GB file.
    I shutdown Vuze and deleted the file and problem solved!

    [​IMG]

    I found this at:
    Users/username/Library/Application Support/Azureus/torrents

    Hope this helps!
     
  9. VegaOrion macrumors newbie

    Joined:
    Jan 1, 2012
    #9
    Same Problem?

    I'm running lion and I had at least 20GB when I realized something was up. I deleted the spotlight files in the one library folder. (go to file couldn't find the other library) I restarted and still it decreases while spotlight's index time to completion skyrockets.

    I heard that I ought to put my HD in the spotlight private section in preferences. It immediately stopped indexing and I had 2GB and fluctuating a few MB now and then instead of 145MB .
    I restarted and took the HD out of private and now my HD looks like this.
    Screen Shot 2012-01-01 at 10.32.20 PM.PNG

    I'm at 760MB since I uploaded the snapshot! Please help!
     
  10. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #10
    For space issues, there are a few things you can try:
    • Begin by restarting your computer as a first step. This sometimes resolves issues.
    • Search with Finder to see if the space is being consumed by a very large file or several large files. Adjust the 50GB in the illustration to whatever size you deem appropriate.
      [​IMG]
    • For Time Machine users on Lion, Time Machine local snapshots may be consuming space.
    • Use DiskInventory X (pre-Lion), OmniDiskSweeper, JDisk Report or GrandPerspective to see how space is being used on your drive. Some of these apps may show more detail than others, so try several.
     
  11. VegaOrion macrumors newbie

    Joined:
    Jan 1, 2012
    #11
    Thanks. I don't have TM but I'll try the s/w you suggested. Hopefully my space won't diminish and crash me before the scan is complete.
     
  12. VegaOrion macrumors newbie

    Joined:
    Jan 1, 2012
    #12
    Grand Perspective helped out a lot. There was a recovered email that's been self replicating and causing all sorts of havoc. I tried everything I could think of and it kept respawning. I finally had to delete the account.

    Ten minutes later it figured out the account wasn't there and I've got 30GB instead of my original 20GB!

    Spotlight is still being weird and I'm experiencing more frequent fluctuations which could be spotlight or apple mail trying to re-download the deleted emails but it seems to stay in the 30-33GB range.

    Time will tell. Thx all!
     

Share This Page