Hard drive spins up periodically, even with sleep option enabled

Discussion in 'Mac Pro' started by AdiosVista, Dec 28, 2008.

  1. AdiosVista macrumors 6502

    Joined:
    Sep 10, 2008
    #1
    I have a 2008 Mac Pro with the original OSX drive and then two other hard drives, one I use for Boot Camp/Fusion and the other for my work files. Under Energy Save in system preferences, I have it so that the drives will sleep whenever possible. The issue I'm having is one of the drives, I think the one with my work files, will wake from sleep every 15 minutes or so even if I'm not accessing any of the files. I haven't timed it exactly but it's around 15-20 minutes and happens throughout the day. What is causing the drive to wake? I disabled iStat Pro because before the drives would spin every time I checked my dashboard so that's not the problem anymore. Any ideas? Thanks.
     
  2. AdiosVista thread starter macrumors 6502

    Joined:
    Sep 10, 2008
    #2
    Did some more tests today, tried unplugging all unnecessary peripherals like iPod, etc., still no luck. My sleeping hard drive will wake on it's own even when I do not access it and it is consistent. Anyone have this issue?
     
  3. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #3
    Could it be that Spotlight is indexing the drive and it's contents?
     
  4. AdiosVista thread starter macrumors 6502

    Joined:
    Sep 10, 2008
    #4
    Thank you for the response. I'm not really sure, how would I know if Spotlight is doing this? Is there a way to disable that from happening? The second issue I'm having with my Mac Pro is it's not going to sleep naturally anymore. Under Energy Savings, I have it set to sleep after 20 minutes but only the monitor sleeps and the computer keeps chugging along. I have a feeling these two issues are related, like the hard drive keeps spinning up and not allowing the machine to sleep on its own.
     
  5. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #5

    Seems you have some really odd behaviour there. Mind if you check the energy saver's options, perhaps it's waking up due to network administration access from other systems and hardware on your network? How about checking the BlueTooth control panel too, under the "advance" section.

    Sorry, as far as I know it's not possible to stop or disable Spotlight from indexing the drive. The whole purpose of it's indexing is to catalog it's contents, that's why it's called HFS+ "Journaled".
     
  6. AdiosVista thread starter macrumors 6502

    Joined:
    Sep 10, 2008
    #6
    I have bluetooth completely turned off. I did, however, have "Wake for Ethernet network administrator access" turned on. What happens if I disable this?
     
  7. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #7
    Means other systems or console on your network can't wakeup your MacPro, cause with it active, your Mac can wake up whenever another system tries to communicate with it. Besides, there's no harm disabling it for the sakes of an experiment, is there?
     
  8. AdiosVista thread starter macrumors 6502

    Joined:
    Sep 10, 2008
    #8
    Disabled it, same results though, computer still won't sleep on its own.
     
  9. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #9
    OK. I would advise you to try this...

    http://support.apple.com/kb/HT1806

    It should resolve your problems. However, if that doesn't work, then I've exhausted pretty much everything I know when it comes to MacPro's and Insomniac states.
     
  10. lostngone macrumors demi-god

    lostngone

    Joined:
    Aug 11, 2003
    Location:
    Anchorage
    #10
    Dtrace

    Download the Apple developer tools and run Instruments.

    When you run it pick "File Activity" and then pick "All Processes" above "Default Target" you can remove the "File Attributes" and "Directory I/O" Instruments and then press record. Then wait and you will see what activity is going on.

    I don't think the system will spin the drives down because of Instruments(but it may) even if it doesn't you should still be able to trap what is happening every 15 minutes.
     
  11. AdiosVista thread starter macrumors 6502

    Joined:
    Sep 10, 2008
    #11
    Thank you both. These sound like great tests for each problem. I will post back with results.
     
  12. Catch Them macrumors regular

    Joined:
    Jul 29, 2008
    #12
    an SMC and PRAM reset may help.


    But are you accessing folders or certain programs on your computer?
    Ie; Aperture, Photoshop, etc etc?

    because some apps look for other drives on the system, it happens on mine and with a macbook i use when i have an external hooked up.

    and opening folders will wake the drive itself at somepoints.
     
  13. bearcatrp macrumors 68000

    Joined:
    Sep 24, 2008
    Location:
    Boon Docks USA
  14. AdiosVista thread starter macrumors 6502

    Joined:
    Sep 10, 2008
    #14
    No luck on resetting SMC, very odd. I didn't get to try the apple developer tools yet. The only external thing I have hooked up that would access files on the sleeping drive is an external hard drive but it is always turned off until I want to back up using Time Machine. I can't unmount the drive because I still need to access it quickly fairly often.
     
  15. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #15
    This is a fairly common problem, with no known cause or solution.

    One of our iMacs does almost exactly the same thing. The drive sleeps even though the Energy Saver settings are for it to never sleep. That would not be so bad if it didn't also spin up about every 30 seconds. This Mac also refuses to go to sleep on its own. This is not the only Mac I've owned with this form of insomnia. Every reasonable solution has been tried, far beyond what has been suggested here -- nothing helps.

    Anyone who solved this problem would win the Mac equivalent of the Noble Prize.
     
  16. MadDog31 macrumors 6502a

    Joined:
    May 20, 2007
    #16
  17. AdiosVista thread starter macrumors 6502

    Joined:
    Sep 10, 2008
    #17
    Good find! I'm going to give this a try. Thanks.
     
  18. Sakyant macrumors newbie

    Sakyant

    Joined:
    Oct 15, 2015
    #18
    Its the Nobel prize, not Noble Prize

    I would say that the cause of this is that somebody is accessing the computer and uploading files to themself or downloading files to it. My Mac does it but it stops when i switch off network. It happens on all my Macs (own 4)
     
  19. ssls6 macrumors 6502a

    ssls6

    Joined:
    Feb 7, 2013
    #19
    You can try this in the terminal

    sudo touch /Volumes/My_Disk_Name/.fseventsd/no_log
     
  20. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #20
    I used to have this problem too. I had to disable all sharing and remote login. If you have a network drive or shared services this could be your issue.
     
  21. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #21
    Thanks for correcting my typo. Something was bothering me from seven years ago, now I know what it is.

    No, that was not the cause. Eventually it stopped on its own, probably the result of a system update.
     

Share This Page