Hard Drive working in Windows - not OS X.

Discussion in 'Mac Basics and Help' started by Poogis, Jul 10, 2008.

  1. Poogis macrumors member

    Joined:
    Jun 2, 2006
    Location:
    London, UK
    #1
    Hello.

    I recently swapped my MacBook Pro's stock 120gb HD with the WD 320gb version.

    I then bought a generic SATA to USB 2.5" enclosure to house the 120gb HD and I have had nothing but problems since, but only in Mac OS X it seems.

    I have tried and tried to format the damned thing using Disk Utility as all the Mac options (GUID, Apple Partition). But the only time it works is when I start up in Boot Camp under Vista and format the HD as NTFS. It reports the disk as healthy and no problems. Using Mac OS 10.5 at home and 10.4 at work the HD in its enclosure will just not work. The common problems are that the disk won't unmount or it won't copy complete files. In other words, complete instability under Mac OS X.

    Could anyone shine a light on this problem? Has anyone else encountered such behaviour with HD enclosures?

    I am now in the process of backing up my PS3 system to it as I managed to format it using Disk Utilty (10.5) as FAT32, just to make sure the drive works. The eBay seller I purchased this from suggested a lack of power from the USB ports but OS X will let the user now with an alert, shouldn't it?

    Thanks in advance.
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Cheap enclosures might need their firmwares to be updated to work properly.
     
  3. Poogis thread starter macrumors member

    Joined:
    Jun 2, 2006
    Location:
    London, UK
    #3
    The PS3 backup got to about 75% and errored. I really doubt it is the hard drive.

    Any idea how I would update the firmware on the enclosure?

    Cheers!
     

Share This Page