Hard drives keep becoming unwriteable

Discussion in 'Mac Basics and Help' started by Soundhound, Jul 7, 2013.

  1. Soundhound macrumors 6502a

    Joined:
    Mar 29, 2006
    #1
    I'm thinking this is some kind of system bug I've got on my iMac (27" 2.93GHZ i7). I keep a few drives connected at all times, and every now and then one of them becomes 'unwriteable'. I run Disk Utilty on it, all I generally need to do is just verify the disk, and it's back to normal. But it keeps happening, and at one time or another to any of the drives that are attached.

    Anybody have an idea what could be causing this/what I should do to troubleshoot/make it stop happening? thanks!
     
  2. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #2
    Does ejecting it and remounting it fix the problem?

    Also you might try reading the log file
    find it in /var/log/system.log
    If there are errors they might get written there. I think you need to be logged in via an admin account to read the log file.
     
  3. Soundhound thread starter macrumors 6502a

    Joined:
    Mar 29, 2006
    #3
    Not sure if ejecting and remounting fixes it or not. My guess is not, it usually requires me opening Disk Utiltity and running verify disk. But I'll check next time it happens.

    As for the log file, is that a terminal thing perhaps? I'm way out of my depths with anything like that I'm afraid....



     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    Does it seem like the disks are "spinning down" after being idle for a while?
     
  5. Soundhound thread starter macrumors 6502a

    Joined:
    Mar 29, 2006
    #5
    Also not sure about that. I'll look for that? Not sure what you mean by spinning down. Don't drives normally go quiet when not accessed for awhile?


     
  6. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    Well, I was thinking the effective thing you're doing with Disk Utility is "waking" the drives.

    What type of drives are they (brand, size)?

    I have a few 3.5" drives in Rosewill enclosures that are connected via USB. I don't think I ever had an "unwriteable" problem, but the drives would be very slow to respond when accessed because of spinning down.

    "Keep Drives Spinning" took care of my issue. You didn't say what OS version you're running. If you decide to try it be sure to read the comments on that page regarding OS 10.8.
     
  7. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #7
    Try this with the problem drive(s):

    Disconnect all external drives.

    Connect ONE of them, let it mount on the desktop.

    If you need to run Disk Utility to "fix it" first, do so.

    When the drive icon is mounted, do this:

    Click ONE TIME on the drive's icon to select it.

    Type "command-i" to summon up the "get info" box.

    Look towards the very bottom of the info box. You should see "sharing and permissions". If the details are hidden, click the "disclosure triangle" to see them.

    At the lower-right there will be a "lock icon". Click it and enter your administrator password.

    At the very bottom there should be a checkbox "Ignore ownership on this volume". Put a check into it and close the Get Info box.

    Now, drag the drive icon to the trash. Wait until the icon disappears and disconnect the drive.

    Wait a few seconds and re-connect it to the Mac.

    Do you still have the same problems?
     
  8. Soundhound thread starter macrumors 6502a

    Joined:
    Mar 29, 2006
    #8
    Thanks Brian, I'll look into that app. I'm thinking it might be something along the lines that Fishrman is suggesting....



    ----------

    I think it does have something to do with permissions, or something like that.

    I tried getting info before disconnecting the drives, and after disconnecting and reconnecting them as you suggested. Both times the Get Info shows the Ignore ownership on this volume as checked.

    In the list of who can read or write, there is my name and the priviledge is set to read and write, same for 'Everyone'. There is a third identity listed, also with Read and Write chased. That identity is listed as 'Fetching' and there is an ellipses (...) after it, suggesting that it's looking for something? It's the same on both drives.

    I think the problem I've had with the drives often comes soon after or immediately after a crash. They don't happen that often, but I do a lot of work in Logic, and often have many gigs of audio samples up, and sometimes I get a crash.

    Anyway, any idea what that 'Fetching' identity might be? It's looking for something? Should I delete it perhaps and see if that helps?

    Thanks Fishrman!!

     

Share This Page