Hard drives not mounting anymore

Discussion in 'Mac Pro' started by Enrico, May 8, 2012.

  1. Enrico macrumors 6502

    Enrico

    Joined:
    Feb 6, 2007
    Location:
    Milano / Roma
    #1
    Hi guys

    I have this problem: my MP has latest Lion and being logged with primary user, ALL the external drives and usb sticks do not get mounted automatically.
    I have to manually go to Disk Utility and mount them, while with another (guest) account they show up in the finder without doing anything.

    I already did a clean install, just used Data Rescue to recover an old dead HD and that's it.....any idea what that could be?
    I'm really frustrated :(
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Sounds like some sort of corruption in the account. Hard to say where it originated.

    I'd say switch to a new admin account (check it first, too). Fairly simple to move and change ownership of files/folders with a few terminal commands.
     
  3. Giuly macrumors 68040

    Giuly

    #3
    Code:
    sudo launchctl load /System/Library/LaunchDaemons/com.apple.diskarbitrationd.plist
    Might help.
     
  4. Enrico thread starter macrumors 6502

    Enrico

    Joined:
    Feb 6, 2007
    Location:
    Milano / Roma
    #4
    I have finally resolved by a new clean install... Well, I guess next time I will use Data Rescue Diskwarrior and all that stuff, I will do it from a separate account just in case!!
     

Share This Page