Hard drives sleeping in spite of Energy Saver settings

Discussion in 'Mac Pro' started by Ino, Sep 24, 2013.

  1. Ino macrumors member

    Joined:
    Aug 11, 2005
    #1
    Hi guys,

    Lately I've been noticing that the RAID volumes in my Mac Pro seem to spin down/go to sleep when I'm away from the computer even when I've UNCHECKED the "Put hard disks to sleep when possible" setting in System Preferences -> Energy Saver. I have display sleep set to 15 min and computer sleep set to Never.

    Not sure what has changed recently other than using me filling the drives more, but I'm only recently starting to hear my 4 hard drives spin up when I return to the computer. During this time disk-related apps (such as Finder, Disk Utility, and so on) are anywhere from laggy to unresponsive, up to about a minute since they spin up one after another instead of all at once (it's a soft beep followed by spinning, 4 times). My desktop wallpaper sometimes disappears for awhile (just see a gray background) which I'm guessing is because it's in an iPhoto Library that's on one of these RAID volumes.

    Disk utility doesn't report any errors upon verifying and repairing disk.

    Any ideas on how I can avoid the spinning up and down of the drives? I'm really looking to get rid of the spin-up lag and have the drives obey my Energy Saver settings...

    Thanks for any advice!

    A few more details just in case:
    - 2009 Mac Pro, OS X 10.8.5 Mountain Lion
    - Boot disk is a SSD on Sonnet PCIe card
    - RAID volumes are for storage only (no OS)
    - Running a RAID 0 in Bays 1+2 (3TB+3TB), and another RAID 0 in Bays 3+4 (3TB+3TB).
    - Both RAID volumes are at about 45% capacity (55% free)
     
  2. Studio K macrumors 6502

    Studio K

    Joined:
    Feb 17, 2013
    Location:
    United States
    #2
    This is happening to a lot of people. It appears to be to do with the recent 10.8.5 OS X update.

    Try this: Set Display Sleep to NEVER. The Hard drive spin-downs appear to be tied to display sleep. I just use a screen saver.
    I've not experimented with this extensively so it may or may not solve the problem. But, so far it seems to be working for me.
     
  3. Ino thread starter macrumors member

    Joined:
    Aug 11, 2005
    #4

Share This Page