Hard drives spinning down when they shouldn't

Discussion in 'Mac Pro' started by badlydrawnboy, Sep 22, 2013.

  1. badlydrawnboy macrumors 65816

    Joined:
    Oct 20, 2003
    #1
    I have a Mac Pro 3,1. I just updated to 10.8.5. After doing that, I noticed that they're spinning down/sleeping. I can tell because when I try to access a file on one of the drives I have to wait for it to wake up.

    In Energy Saver I have "Put hard drives to sleep when possible" unchecked.

    Anyone else noticing this?
     
  2. Studio K macrumors 6502

    Studio K

    Joined:
    Feb 17, 2013
    Location:
    United States
    #2
    yes, I have noticed this. It's just been happening this week, so it must have started with 10.8.5.
    I can hear the drives power down frequently.
    I'm using 2009 Mac Pro.
     
  3. clamnectar macrumors regular

    Joined:
    May 7, 2009
    #3
    same. maddening! i can't believe i was dumb enough to install the patch
     
  4. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #4
    Apple is preparing us for the New Mac Pro external disk experience. Get us used to spin up/down sleep cycles.
     
  5. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #5
    A lot of people are complaining about the same thing. For some reason it works correctly on my system.
     
  6. costabunny macrumors 68020

    costabunny

    Joined:
    May 15, 2008
    Location:
    Weymouth, UK
    #6
    This happened to me also :( now I have a bash script running to update a keepalive file on each spinning disk at regular intervals.

    Have had to do this before, but never on a Mac.

    easy enough fix, shame it needed it.
     
  7. Stephen Dowling macrumors regular

    Stephen Dowling

    Joined:
    Jul 29, 2009
    Location:
    New Mexico
    #7
    Same thing has happened to me since updating to 10.8.5. All 4 drives in my MP spin down frequently no matter if "Put Hard Disk(s) to Sleep when possible" is applied or not. I did a clean install of 10.8.4 and all drives stayed spinning unless instructed by me to do otherwise. Upon re-updating to 10.8.5, they started spinning down frequently again.

    I can't help but wonder if the constant spin-ups/downs will shorten the lifespan of any of my drives :/
     
  8. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #8
    I haven't tried it myself, but there is a free app called Caffeine that you can get from the App Store. It will probably do the job for you.
     
  9. ItWasNotMe macrumors regular

    Joined:
    Dec 1, 2012
    #9
    Happening to me too. Was intermittent in 10.8.4 and earlier.

    In 10.8.5 - seems that disks spin down according to Display sleep settings, so when display sleeps so do all the external disks I have.

    Doesn't matter whether apps, Finder, Time Machine or whatever are reading/writing...
     
  10. scottsjack macrumors 68000

    Joined:
    Aug 25, 2010
    Location:
    Arizona
    #10
    Oh come on. SATA disks are spinning down to prepare us for TB disks spinning down? Please do explain.
     
  11. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #11
    He's not being serious. It's a joke about the new MP.
     
  12. scottsjack macrumors 68000

    Joined:
    Aug 25, 2010
    Location:
    Arizona
    #12
    Oops, too late in the day. I've lost my sense of humor:confused:
     
  13. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #13
    Same is happening to us MBP people as well, I submitted feedback via Apple's feedback form for OS X.

    My problem seems to be pretty excessive, since the only spinning disk I have is an external USB3 drive I can hear it pretty well...and after the monitor goes to sleep the drive will spin up and down about once per minute for a number of minutes. This is really annoying. Not that I would, but I wonder if anyone could claim this bug has reduced the drives life due to the excessive number of times it spins up and down. It's certainly not good for the drives.
     
  14. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #14
    "Yes!" (best Ed McMahon voice)
     
  15. badlydrawnboy thread starter macrumors 65816

    Joined:
    Oct 20, 2003
    #15
    Has anyone filled out the feedback form to Apple? I assume most folks are just waiting for Mavericks and hoping that solves the problem.
     
  16. JesterJJZ macrumors 68020

    JesterJJZ

    Joined:
    Jul 21, 2004
    #17
    Oh good, I thought it was just me. My G-Raids never spun down when the computer was running until now.
     
  17. Tonsko macrumors 6502

    Tonsko

    Joined:
    Aug 19, 2010
    #18
    Don't know how far anyone got with this.

    I was running plex, and it was shutting down during streaming. As it's a laptop, I didn't want to set it to 'never sleep'.

    I traced it to a particular power setting, in particular, standby. The theory goes that when I was streaming, the laptop shutdown it's network to save power (and in the same process shuts down HDD). It would revive if there was bonjour client around, but I don't have one.

    Code:
    sudo pmset -a standby 0
    sorted out my issue. Try it.
     

Share This Page