'Hard' Muting an MBP's internal Speakers

Discussion in 'MacBook Pro' started by Verdanice, Mar 17, 2008.

  1. Verdanice macrumors regular

    Joined:
    Aug 13, 2007
    #1
    Hey guys,

    So I'm in a lecture as I type this at university on my 15" 2.4GHz SR/4GB.

    I accidentally hit CMD+F5 on my Mac a few minutes ago while aiming for a Photoshop shortcut and activated OS X's voiceover feature. It continued to narrate very audibly even though I muted the speakers (voiceover would re-enable as soon as I did something). I had to plug in a pair of headphones to get into the preferences and disable voiceover and re-mute the sound. By this point the system has made more than a couple embarrassing sounds in a lecture hall of a couple hundred people, and my Adium/Growl then made another login sound a couple minutes later as apparently I had missed the 'mute' button'.

    So, while I know this has nothing to do with OS flaws, I'm looking for a way to disable the internal speakers in a way that requires specific user input to re-enable them. Just a piece of software (or a script/command line) that will 'hard disable', as it were, the speakers, just for that peace of mind that I can't accidentally un-mute at the press of the wrong key or key combination.

    If anybody has a solution in mind or knows of a piece of software that would accomplish this, I would appreciate your input. Thank you very much in advance! :)
     
  2. AliensAreFuzzy macrumors 68000

    AliensAreFuzzy

    Joined:
    May 30, 2004
    Location:
    Madison, WI
    #2
    Not a software solution, but a hardware one. Get an old pair of headphones, cut off the plug, and plug it in to the headphone jack whenever you need to mute it.
     
  3. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #3
    I second using anything in the headphone jack. I actually had a friend that wired a push button toggle switch on his PowerBook to short the headphone jack so the computer thought there was something plugged in and wouln't make noise. He even put a toggle swith on his PowerMac a few months later when he got one, but with that one, he just wired the switch into the wires between the speaker and the logicboard.

    I always carry around a pair of earbuds or a 1/8" to 1/4" headphone adapter both of which will disable the internal speakers of my PowerBook.

    TEG
     
  4. Verdanice thread starter macrumors regular

    Joined:
    Aug 13, 2007
    #4
    That's the only solution I've come up with myself - I might have to do that. I'd obviously prefer to go without the extras (that's why I bought that freaking remarkably useless bluetooth Mighty Mouse, no RF receiver), though. I suppose even a way to temporarily re-map the volume keys to their function keys would work if there's a utility for that, but that still leaves the possibility to enable voiceover accidentally again.

    I'm not fully informed on the power of Terminal, so I'm sure there must be a deeper way to disable audio in there somewhere.. I might have some more research to do.

    Thanks for the responses, if anybody else has an idea I'd love to hear it!
     
  5. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #5
    Two people have had this issue, so it's obviously a problem, but I'm still trying to understand.

    Do you mean even with the master volume icon in the menu bar turned right down, it still makes noises?

    Even with everything turned off in the Sound control panel?
     
  6. Verdanice thread starter macrumors regular

    Joined:
    Aug 13, 2007
    #6
    No - it's not fair to describe it as an OS flaw. It's user preference, really. What's happening is accidental un-muting of the volume via the notebook's dedicated volume keys. The accessibility feature 'Voiceover', though, is a bit intrusive - un-muting no matter what when it has something to say. It can be a loud trip to the preferences pane to shut it up (although perhaps CMD+F5 is a toggle and will work in reverse?).
     
  7. Animalk macrumors 6502

    Joined:
    May 27, 2007
    Location:
    Montreal Canada
    #7
    I have had my internal speakers on my MBP chime at full blast upon boot up even when having my headphoens plugged in. I am actually beginning to think that I have absolutely no control over the boot up chime. It plays when it wants at the volume it wants regardless of what i set my volume at prior to shuting down.
     
  8. Verdanice thread starter macrumors regular

    Joined:
    Aug 13, 2007
    #8
    I'm pretty sure mine was doing that for the first couple months I had it, but I could never remember if I muted the volume before shutting down. I don't have it happen anymore. I do remember,however, that plugging in headphones did not work, nor did merely reducing the volume - it has to be at 0, muted.
     

Share This Page