Harddrive in Enclosure not Recognized

Discussion in 'Mac Accessories' started by bee33, May 31, 2011.

  1. bee33 macrumors newbie

    Joined:
    May 31, 2011
    #1
    Hello,

    I own a 1TB WD MyBook (Purchased December 2010). The connector to the USB broke off. I was told by a technician, who took the harddrive apart, that it was too small to be reconnected and that I should buy an enclosure.

    I purhased a Rocketfish SATA hard drive enclosure kit for a 3.5 SATA hard drive (also has a USB connection and was told would work with macs), constructed the entire thing, and plugged it in. I am now receiving the message that the "disk you inserted was not readable by this computer."

    I am operating a Mac Book Pro, Version 10.4.11 (2.2 Ghz Intel Core 2 Duo, 2GB 667 MHz DDR2 SDRAM).

    The hard drive was formatted for this computer before and worked perfectly. It just seems to have been jostled enough for the connector to break off, but nothing else appeared to be a problem... It was powering up before put in the enclosure, just not able to be connected.

    I have also plugged the harddrive in new enclosure into a Mac Book Pro running 10.6.3 with the same result.

    It gives me the option to initialize, but i absolutely cannot wipe all of this data off without recovering it first.

    Do i have any options other than severely expensive data recovery?

    Thank you!!
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    You could try a program like Data Rescue, but otherwise you are going to have to use a professional recovery service.
     
  3. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    "Do i have any options other than severely expensive data recovery?"

    Yes.
    Try ANOTHER enclosure BEFORE you decide that the drive itself has "gone bad" on you.

    I would recommend one of these:
    http://www.amazon.com/s/ref=nb_sb_noss?url=search-alias=aps&field-keywords=usb+sata+dock&x=0&y=0
    (Note: many items shown, they all work the same way, pick one you like that's cheap)

    Put the drive into the dock, plug it into the Mac, turn everything on, see what you come up with.

    If the drive still shows as "unreadable", then you can probably come to the conclusion that it needs to be re-initialized (since it has failed +two+ attempts to get it to mount in different enclosures).

    If there is data on it that you "have to have", you _may_ be able to use a data recovery app to scavenge the drive and get the data off of it.

    Here are a few apps, in no particular order of preference, they're all good and work the same way:
    - DataRescue3
    - Stellar Phoenix Data Recovery
    - DiskDrill

    It's _possible_ (in no way guaranteed) that a recovery app _might_ be able to recover the drive without having to reinitialize it. TRY THE RECOVERY APP FIRST. Only choose to re-initialize as a LAST RESORT when NOTHING else seems to be working.

    WARNING WARNING WARNING
    If you do re-initialize the problem drive DO NOT use the option to "zero out the data" on the drive. This will end any chance you have for getting the old data back! The ONLY thing you want to do is re-initialize (Note: Disk Utility calls it "erase", but all you are "erasing" is the directory, so long as you don't "zero it out"). Be careful!

    IMPORTANT IMPORTANT IMPORTANT:
    You WILL need ANOTHER drive to serve as a "scratch drive" for the recovery apps to save the recovered files to. This is another reason why you should spend about $30 and buy one of the USB/SATA docks (these are VERY useful accessories to have around).

    So, in addition to ordering the USB/SATA dock, you need to order another "bare drive" to serve as your scratch drive. I suggest newegg.com -- they are my favorite drive vendor.

    You WILL have to pay the registration fees to get the above apps to do anything.

    You WILL have to give the recovery apps sufficient time (in some cases many hours) to do their work, and you WILL have to take the time and effort to learn to use the apps.

    You will probably also lose all pre-existing file/folder hierarchies from the "recovery process". Remember that folder hierarchies are a product of the drive's directory, and when you re-initialize the drive you "wipe that part of it clean". The data itself, however, is still there, and the data recovery apps "go around" directory info and go right to the drive's sectors to scavenge the data.

    Hope this helps...
     

Share This Page