Harddrive Won't Mount

Discussion in 'Mac Basics and Help' started by KidCudi5, Mar 11, 2011.

  1. KidCudi5 macrumors newbie

    Joined:
    Mar 11, 2011
    #1
    When I boot my computer it comes up to the apple logo and has the loading wheel beneth it then after a minute or 2 a bar appears underneath the wheel. The bar stays for a while then leaves, it does this 3 times then the computer shuts down. I then proceeded to boot in single user mode to see if I could find the problem. Every thing boots fine until it tries to mount Disk0s2. It fails and says errno:19
    it tries about 7 times and then says mounted read-only. I then try to boot from single user mode. It then says Disk0s2 I/O error 3 times. and powers down. How do I fix this. I have no startup disk. :eek:
     
  2. KidCudi5 thread starter macrumors newbie

    Joined:
    Mar 11, 2011
    #2
    Details

    I ran single user mode and /sbin/fsck -fy
    ** /dev/rdisk0s2
    ** Root file system
    Executing fsck_hsf
    disk0s2: I/O error.
    ** Checking Journaled HFS Plus volume.
    ** Checking extents overflow file.
    ** Checking catalog file.
    disk0s2: I/O error.
    Invalid node structure
    (4, 13300)
    ** the volume Macintosh HD could not be verified
    /dev/rdisk0s2 (hfs) EXILED WITH SIGNAL 8
    :/ root#
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #3
    Sounds like your hard drive is toast. Boot from your install DVD and run Disk Utility to see if you can repair the disk.
     
  4. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #4
    He does not have a "startup disk" - best bet would be to buy a retail copy of Snow Leopard - but it does sound like that the hard disk is toast...

    What kind of Mac - MacBook or what ??
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    Thanks, I missed that. Yes, a retail copy would work, and would probably be faster than ordering replacement install disks from Apple.
     
  6. KidCudi5 thread starter macrumors newbie

    Joined:
    Mar 11, 2011
    #6
    Update

    I Finally got the system to mount by creating a new user through single user mode. I then proceed to use disk utillity to verifiy. It said the disk need to be repair, but not having a startup disk is frustrating. I then obtained a copy of DiskWarrior from my friend. I used it to repair the disk. It worked fine the first time I booted but then next time I tried it boot with the error loading drivers symbol (Circle with a slash through it). i tried diskwarrior again. but nothin
     

Share This Page