Hardware Issue?

Discussion in 'MacBook' started by JimmyV710, Oct 24, 2008.

  1. JimmyV710 macrumors newbie

    Joined:
    Oct 24, 2008
    #1
    I have a 2006 Black Macbook and I've been using it to pretty much do anything a normal college student does and it functions fine. However, whenever I play World of Warcraft the game plays well for a little while and then all the sudden does this stutter when the sound and game performance lag. On my home wireless network I can usually play through the stutter but it gets aggravating, especially since it distorts the sound. At my dorm I am connected via ethernet cable and it still does the stutter and eventually after 10-20 minutes of play it cuts me off of the internet entirely. Safari, WoW and Adium all cease to work until I restart or put it into sleep mode and wake it up. Here's an example of what the system.log shows.

    Oct 24 14:29:53 jvacs-computer kernel[0]: IOAudioStream0x3e78400::clipIfNecessary() - adjusting clipped position to (86b,9a9)
    Oct 24 14:31:01 j-vacs-computer kernel[0]: IOAudioStream0x3e78400::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (9cf,5be)->(9d1,b1b).
    Oct 24 14:31:01 jvacs-computer kernel[0]: IOAudioStream0x3e78400::clipIfNecessary() - adjusting clipped position to (9d1,5be)
    Oct 24 14:31:53 jvacs-computer kernel[0]: IOAudioStream0x3e78400::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (adc,151f)->(ae5,10a9).
    Oct 24 14:31:53 jvacs-computer kernel[0]: IOAudioStream0x3e78400::clipIfNecessary() - adjusting clipped position to (ae4,151f)

    As you can see by the times it often does this multiple times in the same minute.

    When it does this stutter the Airport bar on the top right goes to zero bars from full and then back again after the 3-4 second lag. This problem rarely occurs in other programs but I have seen it do so a few times. I am unsure of what to do or what to ask for if I go to the Apple store for a fix, I've tried reinstalling the OS (currently running 10.4.11) and WoW multiple times to no avail. I also know that the kernel ring 0 is the main kernel for operations and the log shows that thats causing the error.

    Is there any way to fix this?

    If I do have to go to the Apple store what will they have to do?
     

Share This Page