Hardware or Software Problem w/IMAC??

Discussion in 'Mac OS X Lion (10.7)' started by jj17, Nov 7, 2012.

  1. jj17 macrumors newbie

    Joined:
    Nov 7, 2012
    #1
    I have an Apple Snow Leopard (I didn't see a Snow Leopard forum) computer that a month ago or so quit being functional as I just get the spinning wheel.
    SORRY this post is so long but its been a long process.:confused:

    I have tried about everything except a few things I couldn't get to work somehow.

    And it takes forever to start up so every time I need to shut it down it means coming back later to continue and I'm getting nowhere.

    The latest is: today I did the disk repair and permissions repair for the 3rd time

    The first time the disk repair reported it was successful

    The second time it reported unsuccessful.

    24 hours later the 3rd disk repair and permissions repair (which took over 12 hours together) reported A-OK

    Yet still when i get on it is the same spinning wheel.

    The problem is that it is always tied up and gives the message about You were not logged out because of Firefox something

    And also it says there is a script running do I want to stop it? I would of course select yes but I can't do that because of the spinning wheel.

    Is there some other way in terminal I can figure out what the script is and stop it or something?

    I really really need stuff off this computer asap and after a month I just have gotten nowhere.

    THANKS for reading !:whistle: If you can gimmee a clue to fix this I'd be forever indebted!

    I have minimal Terminal skills but can follow directions. I don't know what is causing the problem so I don't know the fix.

    Also - based on what I've described what's the prognosis for the disk - When the Disk Repair Failed it said back up your stuff and start over basically but then I ran it again and it came up good?

    What is a clean install? someone recommended it but I don't know how. I have a Book for Tiiger but Leopard is different

    I have limited abilities can't download programs to diagnose because its not usable. LOST is me?
     
  2. mohsy90 macrumors 65816

    mohsy90

    Joined:
    Feb 4, 2011
    Location:
    New York
    #2

    Sounds to me like a failing hard drive or either something is corrupt with the current iOS. First thing first, I would backup any files you have to an external HD. Then attempt a clean install. Insert your snow leopard disc and hold "C" on start up to boot from it. You want to go into disk utility and erase the entire drive. You then want to reinstall snow leopard.

    If the problem continues, then its definitely a hard drive issue and most likely will need to be replaced.
     
  3. jj17 thread starter macrumors newbie

    Joined:
    Nov 7, 2012
    #3
    Thank you for the advice and your opinion. I am not sure how to back things up since the computer is non-functional.

    Is there an archive and install on Snow Leopard and might it be worth trying?

    Anyway - thanks for the info:eek:
     
  4. mohsy90 macrumors 65816

    mohsy90

    Joined:
    Feb 4, 2011
    Location:
    New York
    #4
    Well it seems like you can still boot into the OS if its giving you script messages. See if you can attach an external hard drive and either use time machine to back up your data or just transfer them manually.

    To reinstall Snow leopard you'll need to insert the restore CDs that were provided. If you dont have the CDs you can always purchase software using another computer and then create a bootable install USB.
     
  5. jj17 thread starter macrumors newbie

    Joined:
    Nov 7, 2012
    #5
    Thank you - i have not backed up however I have been able to get online with the computer but it is extremely slow. It seems to work ok but its like it has a full buffer you can only type about 2 words a minute then it stops w/spinning wheel

    I have tried using activity monitor but it doesn't respond.

    Is there some program I can download to hopefully work some magic on this machine?

    Thanks
     

Share This Page