Has 10.5.2 fixed the "Input/Output Error" in DiskUtility?

Discussion in 'macOS' started by litedesign, Feb 13, 2008.

  1. litedesign macrumors newbie

    Joined:
    Feb 13, 2008
    #1
    Since upgrading to Leopard, I have been trying to partition my 250GB USB Hard Drive so it can be used for Time Machine, but also for additional external storage.

    Every time I try to partition or reformat the drive in Disk Utility, I get an error: "Disk Erase failed with the error: Input/Output Error".

    According to posts all over the internet, this is a bug in Leopard and can be worked around by booting with a Tiger DVD and running Disk Utility there.

    Does anyone know if this issue has been resolved in 10.5.2?

    Ethan
    15" MacBook Pro 2.4GHz Intel


    For reference, here is a sampling of other posts detailing this problem:

    http://discussions.apple.com/thread.jspa?messageID=6507054

    http://blogs.unixfu.net/2008/01/08/leopard-bug-inputoutput-error-in-disk-utility.html

    http://forums.mactalk.com.au/showthread.php?t=38885
     
  2. litedesign thread starter macrumors newbie

    Joined:
    Feb 13, 2008
    #2
    Just a followup -- I found my original Tiger DVDs and was able to boot into Tiger and reformat my hard drive using Disk Utility.

    I have read elsewhere that this issue has not been resolved in 10.5.2.
     
  3. dgalvan123 macrumors 6502a

    Joined:
    Feb 16, 2008
    #3
    Interesting. . . I am having this very problem. . . but the strange thing is that I was able to format a brand new 250 GB 2.5 inch drive which I had put in an external enclosure about a month ago. I formatted that drive and then used it to replace the 80 GB drive that was in my Al powerbook (1.67 GHz). I was running OS 10.5.2 at the time, and disk utility had no problem formatting the brand new drive.

    Now, a month later, I decided I wanted to put the 80 GB HD I took out of my Al book into my Ti book (400 MHz), so I plugged the firewire external enclosure with the 80 GB drive in it into my Ti Book. The drive basically hung (could see the drive on the desktop, but got an infinitely spinning beachball when I tried to open it), so after 10 minutes or so of no joy I disconnected the drive. Since then I have had the same problem described in this thread: Can't see the external drive on the desktop, but can see it in Disk Utility, and all attempts to reformat it by using Disk Utility's erase command fail with a message like "Input/Output error" or "Resource busy" or "the underlying task reported failure on exit". I get the same thing whether I'm using the firewire capability, or the USB 2.0 connectivity of the drive. Same thing whether I plug it into the TiBook (which runs OS 10.4.11) or the AlBook (which runs 10.5.2).

    it sounds like using the disk utility on the Tiger DVD would work. . . except I can't find my Tiger DVD. . .

    But what's weird about this is two things: 1.) I was able to successfully erase and reformat that 250 GB drive over a month ago using 10.5.2 and Disk Utility with no problem. 2.) I was able to mount the 80 GB drive many times just to look at its contents with no problem. The problem only started for me after I tried plugging it into the TiBook, the drive hung, and I had to disconnect it. I don't mind if I corrupted the data on the drive, it's all backed up elsewhere, but I was hoping to use this as my new internal TiBook drive, and I just can't erase the darn thing!
     
  4. redanzl macrumors newbie

    Joined:
    Apr 17, 2008
    #4
    I just encountered this problem when I replaced my Al G4 PowerBook's hard drive. I put the old 80 GB one in an external Firewire case and tried to re-initialize it, only to get the "Disk erase failed - input/output error" message. I wasn't able to fix it with my Tiger disk.

    I bought an external USB 2.0 case that I put the 80 GB drive in, and I was able to re-initialize the disk with no problem. After that, I put it back into the FireWire case, where I was able to initialize the disk.

    So for those who find this thread like I did, if the Tiger method doesn't work, and you have access to a USB enclosure, you may be able to reformat the drive via USB.
     

Share This Page