Has anybody managed to jail break a uk iphone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by gazzzmoly, Nov 12, 2007.

  1. gazzzmoly macrumors regular

    Joined:
    Jul 3, 2007
    #1
    hi all I was wondering if anybody had Mandes to jailbreak a I'm based iPhone.

    I have manger to downgrade to 1.1.1 and used jailbreakme.com worked fine however I could not activate the phone. I used installer.app and installed the prep tool. Upgraded back to 1.1.2 which again went fine. This time I has o2 service. However no installer.app anymore. I then tried using the new jailbreak software. After getting other the initial problem with not finding the jar file. I know get the message that says my iPhone is connected. Everythingelse is fine though. Syncs with itunes fine just no installer and mo jalbroken I'm phone.
     
  2. quixers macrumors member

    Joined:
    Nov 12, 2007
    #2
    I'm wondering the same - just want my o2 activated iphone jailbroken for 3rd party apps!

    Are you sure you are *UPDATING* back up to 1.1.2 rather than restoring? Restoring will erase the apps and the okToPrep app.. Noticed this mistake was made by some of the US guys on other forums.

    If you do get it jailbroken and on 1.1.2 I reckon you're prob one of the first!

    Let me know how you get on.
     
  3. gazzzmoly thread starter macrumors regular

    Joined:
    Jul 3, 2007
    #3

    yup you where right i was restoring i am a true mong trying again back to 1.1.1 for me lol
     
  4. gazzzmoly thread starter macrumors regular

    Joined:
    Jul 3, 2007
    #4
    i tried updating and i get an error (1406) so i am guessing this is a no go for now
     
  5. quixers macrumors member

    Joined:
    Nov 12, 2007
    #5
    Sorry to hear it didn't work. Did you manage to get your phone working again ok?
     
  6. gazzzmoly thread starter macrumors regular

    Joined:
    Jul 3, 2007
    #6
    sort of no edge or you tube through gprs though ?


    can you tell me your modem firmeare version if you are in the uk please
     
  7. capra123 macrumors newbie

    Joined:
    Nov 13, 2007
    #7
    Same problem Jailbreaking O2 phone

    I have exactly the same issue. Upgrade after OkToPrep keeps failing with a 1402 error. Restore will always work fine but no good for a jailbreak. I have a sinking feeling that it is an iTunes 7.5 issue?:confused:
     
  8. iphoneuser007 macrumors newbie

    Joined:
    Nov 13, 2007
    #8
    Modem Firmware is 04.02.13_G
     
  9. talazem macrumors newbie

    Joined:
    Oct 10, 2007
    #9
    While I had no interest in "unlocking" the phone (I signed up with o2), I did want access to the apps that have been developed, and to be able to use my iphone as a storage device (to see it as a hard-drive on the mac). As such, I followed the directions posted on http://conceitedsoftware.com/iphone/site/112jb.html. It worked fine on my UK o2 phone.

    Again, to stress the point, I did *not* try unlocking the phone, so if that's what you want, I can't comment. Just jail breaking it.

    I have run into one problem, and am wondering if others have as well: I've been unable to use Visual Voicemail. When I press the button for it, it dials up o2's normal voicemail. I don't know if this is a problem of coverage which I hadn't noticed before doing the jail break, or if it is truly a result of the jail break.

    Anyone have any ideas?
     
  10. gazzzmoly thread starter macrumors regular

    Joined:
    Jul 3, 2007
    #10
    That's the tutorial that I followed I manage to downgrade and jailbreak but when I try to upgrade it says preparing iPhone for upgrade then it errors and puts my iPhone into recovery mode I am then left having to restore back to 1.1.2 and that kills the jail break to solve your problem there is a way you need to ssh into the phone I will see. If I can. Find the link
     
  11. talazem macrumors newbie

    Joined:
    Oct 10, 2007
    #11
    Hi Gazz...

    Have you found that link by chance?
     
  12. talazem macrumors newbie

    Joined:
    Oct 10, 2007
    #12
    OK, what I've discovered is that of you do jailbreak your o2 UK iphone by doing the 1.1.2 > 1.1.1 > re-upgrade method, you will lose Edge and Visual Voicemail.

    However, this link -- http://code.google.com/p/iphone-elite/wiki/o2ukJailbreak -- describes how to get them back so that your phone is as new, but now jailbroken so that you can install apps.

    These are the instructions, taken straight from the site:

    O2 Specific

    If you're using O2 you'll now have an activated, jailbroken iPhone with 1.1.2 firmware (again) and a working phone.

    However, VisualVoicemail and EDGE will not work properly - this is easily fixed, simply install BSD Subsystem and OpenSSH using Installer.app and then SSH into the iPhone and type the following two commands;

    rm /var/root/Library/Preferences/com.apple.carrier.plist

    ln -s /System/Library/Frameworks/CoreTelephony.framework/Support/O2_UK.plist /var/root/Library/Preferences/com.apple.carrier.plist

    rm -f /var/root/Library/Preferences/SystemConfiguration/preferences.plist

    Reboot your iPhone, and all going well you'll now have EDGE and VisualVoicemail working again

    You now have a 1.1.2 O2-UK iPhone with all the third party apps you could want. Enjoy :)

    It saved me.
     
  13. larrymassive macrumors newbie

    Joined:
    Nov 7, 2007
    #13
    can this be done with iphonebrowser? i dont understand how to work iputty. You say type thefolloing 2 commands but i see there is 3 ?
     
  14. pw1500 macrumors regular

    pw1500

    Joined:
    Oct 31, 2007
    Location:
    Oxford, England
    #14
    Enable EDGE and Visual Voicemail

    1. Find your iPhone's IP address (tap the Settings icon, select the Wi-Fi option, then tap the blue arrow next to your network name to get this information).

    2. Open a Terminal window.

    3. Type "ssh root@{iPhone IP address}", substituting your own address as appropriate (e.g. "ssh root@192.168.1.2").

    4. You will be prompted for a password - enter the password you chose when jailbreaking your iPhone.

    5. Enter the following command into the terminal window and press Enter:
    cp/System/Library/Frameworks/CoreTelephony.framework/Support/O2_UK.plist /var/root/Library/Preferences/com.apple.carrier.plist && rm -f /var/root/Library/Preferences/SystemConfiguration/preferences.plist && reboot

    6. Your iPhone will restart, and EDGE and Visual Voicemail will now work.
     
  15. larrymassive macrumors newbie

    Joined:
    Nov 7, 2007
    #15
    ok i get to the putty command screen and enter the ssh root@192.168. etc...

    then i press enter then i type the password but it says access denied? wen i try typing the password the cursor does not move but i a sure this is not the problem. the password i am using is alpine and i have also tried changing it with a few programs but with still no luck.

    I have jailbroken lots of times now to try changing the jailbreak password but still cant get this edge/wifi problem to fix

    what am i doing wrong? Please can someone help!! I'm loving my modded phone but cant seem to be able to live without mobile internet much longer so i am going to go back to the boring iphone but with internet

    thanks to the last poster because i have got further with there help but stuck on the password part, seems like the alpine password works for others but me and i cant figure out why (the password is always set to alpine when i jailbreak and i never change it, i only changed it to test to see)

    I am using putty, is there any settings i need to change? why is the password saying access denied when i put the correct password in?

    thanks in advance
     
  16. iphoneuser666 macrumors newbie

    Joined:
    Dec 30, 2007
    #16
    Although I am all setup to use ssh, I actually found it easier to use "iPhoneList" which is GUI browser. Once I had replaced com.apple.carrier.plist with the 02_UK.plist (changing the name in the process) and removing the preferences.plist I once again had working GPRS. I am not in an EDGE area at the moment so will have to wait.
    Going off on a tangent now: The girl at the O2 store told me that they had 99% EDGE coverage. I took note of her name on her name tag and noticed she was a trainee :). I rang O2 this morning and the person I spoke to didn't have a clue about EDGE.
     

Share This Page