Has anyone been able to downgrade an iPhone 3GS to 3.0?

Discussion in 'Jailbreaks and iOS Hacks' started by andrewwg94, Oct 12, 2009.

  1. andrewwg94 macrumors member

    Joined:
    Aug 5, 2009
    #1
    right now i have 3.1 jailbroken with blackra1n. cydia says that i have an eccid file blah blah. form my understanding, that file is used in downgrading since it contains my phone signature. i'm just wondering if anyone actually HAS downgraded to 3.0 on a 3gs. link?

    UPDATE: I was able to easily downgrade it to 3.0, but my phone was generically activated, so i had no att activation and therefore not att service. anyone able to get signal after downgrading to 3.0? (see my other post for link to the guide i used)
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Some have done it. Saurik has info on this. It takes some doing.

    http://www.saurik.com/id/12
     
  3. aleni macrumors 68020

    Joined:
    Jun 2, 2006
    #3
    i've sucessfully downgraded my factory unlocked my 3gs from 3.1 to 3.0. but it's not giving me a cellular network. so no use for me since the baseband has been upgraded. i upgraded it back to JB 3.1 usingpwnage tool.
     
  4. Diode macrumors 68020

    Diode

    Joined:
    Apr 15, 2004
    Location:
    Washington DC
    #4
    Yea downgrading won't downgrade your baseband in case your hoping to unlock if you accidentally upgraded.
     
  5. andrewwg94 thread starter macrumors member

    Joined:
    Aug 5, 2009
    #5
    i found that out the hard way. anyone has any idea? i believe it's because redsn0w tried to activate it itself, not the at&t way...

    ahh...
     
  6. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #6
    What idea ?

    It is simple, on a 3GS once you update to official Apple 3.1 firmware, your baseband gets updated to 5.11.xx and there is no way to downgrade it or unlock it.

    If you have your SHSH on file, you can downgrade the firmware, but not the baseband.
     
  7. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #7
    I successfully downgraded my 3GS using my Cydia SHSH. It was really easy. All you have to do is add one line to your hosts file and then option-restore or shift-restore to the 3.0 ipsw. Ignore the 1500 error.
     
  8. The General macrumors 601

    Joined:
    Jul 7, 2006
    #8
    No, that's all YOU had to do. You must be one of the 50,000 that got their 3.0 ECID SHSH on file with Cydia.

    It's not possible to downgrade an iPhone 3G S to 3.0 unless you:

    1. Are one of the 50,000 that got their 3.0 ECID SHSH on file with Cydia during "the window".
    2. Sneak into 1 Infinite Loop and turn on firmware signing for 3.0 again.
     
  9. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #9
    Well, since that's what the OP was posting about, I will confess that I think my post more relevant to this thread than yours. The OP said he has his SHSH on file and wanted to confirm that the downgrade actually works.

    Why don't you take your bitching and moaning elsewhere? I thought by now you'd have learned it's not welcome here.
     
  10. andrewwg94 thread starter macrumors member

    Joined:
    Aug 5, 2009
    #10
    calm down guys. back to topic. i am one of those people that had their ecid with seurk's server. i used it to downgrade, my problem is that the phone does not activate with att after the downgrade. from the guide i used (excellent guide btw) was (http://modmyi.com/forums/3g-s-downg...gs-restore-verification-server-ecid-shsh.html), i was supposed to use pruplerain, not redsnow. the problem with purplerain is that it crashes when i try to j/b with it! any ideas why? i'm sure that's the solution to my problem. i couldn't find anything by googling.
     
  11. JUSTQUAN macrumors member

    Joined:
    Jul 3, 2009
    #11
    yes please i need more info on this. i am on my 3rd restore of this phone. i lost my visual voicemail after going to 3.1.2 and im not to happy about it. i thought it was because of the blackra1n jailbreak but i was wrong. at&t of course has no answer. no i lost my lovable and addicting jailbreak and damn near the phone.
     
  12. The General macrumors 601

    Joined:
    Jul 7, 2006
    #12
    Bitching and moaning?

    "I have an ECCID [sic] file blah blah"

    Yes, anyone with Cydia on their phone has an ECID SHSH on file, but unless it says "3.0 ECID SHSH" then he CAN NOT I REPEAT CAN NOT down grade to 3.0. Only the 50,000 or so people who got their 3.0 ECID SHSH on file can down grade.

    Stop fluffing up your feathers and go back into the coop.

    Cool story, bro. Use redsn0w if purplera1n crashes. If neither of them work, then you should probably restore and try again. If it still doesnt work, then you should upgrade to 3.1.2 and use blackra1n. Since you're not unlocking, you should probably just upgrade to the newest firmware anyway.
     
  13. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #13
    ^^^^
    I could be wrong, but I think thelatinist is confusing you with the other General, who is no longer with us. :)
     
  14. The General macrumors 601

    Joined:
    Jul 7, 2006
    #14
    there was another general? i was unaware.
     
  15. strike1555 macrumors 6502

    Joined:
    Jun 29, 2009
    #15
    Are you sure there's another one?

    It sounds like the same buffoon with a tampon stuck up his a**.
     
  16. andrewwg94 thread starter macrumors member

    Joined:
    Aug 5, 2009
    #16
    has anyone gotten there's activated when they used purplera1n? does purplera1n not crash for you guys?
     
  17. optophobia macrumors 6502a

    optophobia

    Joined:
    Oct 26, 2007
    Location:
    Hudson MA
    #17
    Maybe you should clarify for the record and to prevent any more fighting on this thread : you do have the 3.0 ECID SHSH on file with cydia and not the 3.1 correct ?
     
  18. andrewwg94 thread starter macrumors member

    Joined:
    Aug 5, 2009
    #18
    yes i have the 3.0 ECID SHSH. i thought i made it clear in my 1st post.
     

Share This Page