Has anyone been able to find a way to disable the "Do not disturb" notification?

zorinlynx

macrumors 603
May 31, 2007
5,413
6,185
0
Florida, USA
zorin.org
I keep my iPad on Do Not Disturb all the time, because I don't want to receive notifications on it. I'd like to see them on the screen when I pick it up, but I don't want the iPad "Going off" randomly; I'd rather get those notifications on my phone.

The pictured notification keeps appearing and I have to keep dismissing it; it's annoying. Is there a way to make it go away permanently while leaving Do Not Disturb on? Or am I cursed to see it forever?

IMG_0054.jpg
 

MEJHarrison

macrumors 65816
Feb 2, 2009
1,343
1,145
0
I didn't want notification on my old test phone (6+), so I went to Setting -> Notifications and simply turned them all off. I don't see that message on my device or get any notifications at all on that device.
 
  • Like
Reactions: martyjmclean

zorinlynx

macrumors 603
May 31, 2007
5,413
6,185
0
Florida, USA
zorin.org
I didn't want notification on my old test phone (6+), so I went to Setting -> Notifications and simply turned them all off. I don't see that message on my device or get any notifications at all on that device.
That's just it, though, I still want notifications, just not when the screen is off. DND is perfect for that, but now it pops up this annoying banner.
 

GreyOS

macrumors 68040
Apr 12, 2012
3,265
1,550
0
Last month I submitted a suggestion via the Feedback that they should provide an option for this. Perhaps submit one too. Hopefully they will at least consider it.
 

Mr$tone

macrumors 6502
Oct 25, 2017
413
370
0
Last month I submitted a suggestion via the Feedback that they should provide an option for this. Perhaps submit one too. Hopefully they will at least consider it.
There alteady is an option for this.
Instead of using DND, disable notifications for the lockscreen for all apps manually and leave all other notifications on. Then you can browse through the history of notifications just as if DND had been on.
I’ve had this setup on my iPad for ages—it works great!
 
Last edited:

GreyOS

macrumors 68040
Apr 12, 2012
3,265
1,550
0
There alteady is an option for this.
Instead of using DND, disable notifications for the lockscreen for all apps manually and leave all other notifications on. Then you can browse through the history of notifications just as if DND had been on.
I’ve had this setup on my iPad for ages—it works great!
Sorry, but no. That may be a solution for OP’s specific use case but is not a general replacement for DND.

I have DND scheduled and active even when iPhone is unlocked. Both make your alternative infeasible.

I don’t want to see the new banner on the lock screen and so would like an option to turn it off. That is the option this thread is about. Seeing the moon in the status bar is enough.
 

Mr$tone

macrumors 6502
Oct 25, 2017
413
370
0
Sorry, but no. That may be a solution for OP’s specific use case but is not a general replacement for DND.

I have DND scheduled and active even when iPhone is unlocked. Both make your alternative infeasible.

I don’t want to see the new banner on the lock screen and so would like an option to turn it off. That is the option this thread is about. Seeing the moon in the status bar is enough.
Despite your opinion, hopefully someone else see the suggestion as an opportunity •smile•

Btw, have you tried to 3D Touch clicki the DND notification and then click the X (upper right corner)?
 
Last edited:

Shirasaki

macrumors G3
May 16, 2015
9,346
3,373
0
Despite your opinion, hopefully someone else see the suggestion as an opportunity •smile•

Btw, have you tried to 3D Touch clicki the DND notification and then click the X (upper right corner)?
The issue is it will pop back afterwards, which is not fun.
 
  • Like
Reactions: GreyOS

GreyOS

macrumors 68040
Apr 12, 2012
3,265
1,550
0
Despite your opinion, hopefully someone else see the suggestion as an opportunity •smile•

Btw, have you tried to 3D Touch clicki the DND notification and then click the X (upper right corner)?
Hmm, yes, it was a useful tip for anyone who doesn't know it already. It's the way you said "the option already exists" when actually, the option we're talking about doesn't. It's not really despite my "opinion" either - it's despite the facts.

And as the other user posted, the banner appears every time DND is enabled.

Thumbs down.
 

synergize

macrumors regular
Jul 12, 2010
143
211
0
When I enable DND I get a persistent Lock Screen message or note that says: DND is activated and will not allow calls or notifications. How do you get rid of this message, you can swipe left on it and clear it, but it keeps coming back over and over again.
 
  • Like
Reactions: Dsterno52

C DM

macrumors Sandy Bridge
Oct 17, 2011
47,272
15,880
0
When I enable DND I get a persistent Lock Screen message or note that says: DND is activated and will not allow calls or notifications. How do you get rid of this message, you can swipe left on it and clear it, but it keeps coming back over and over again.
Odd, mine doesn't seem to come back once I clear it.
 
  • Like
Reactions: synergize

Rayban

macrumors 6502
Sep 5, 2008
317
323
0
Odd, mine doesn't seem to come back once I clear it.
It may eventually come back. I cleared the message before bed and when I woke up it was back.
Is this their solution for removing the little moon icon at the top info bar? Seems clumsy. I want that little icon back.
 

celer1ty

macrumors member
Oct 20, 2014
33
20
0
Now one must clear the Lock Screen notification each time for Smart Cover to unlock...
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
47,272
15,880
0
It may eventually come back. I cleared the message before bed and when I woke up it was back.
Is this their solution for removing the little moon icon at the top info bar? Seems clumsy. I want that little icon back.
I still have the icon (on my iPhone 7).
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
47,272
15,880
0
Gone with the notch.
Right, but that's basically more of a phone design type of thing that was even there prior to iOS 12 (and probably in some ways related to why they now added this type of lock screen message).
 

Subpopgirl

macrumors newbie
Sep 29, 2018
1
0
0
Texas
I keep my iPad on Do Not Disturb all the time, because I don't want to receive notifications on it. I'd like to see them on the screen when I pick it up, but I don't want the iPad "Going off" randomly; I'd rather get those notifications on my phone.

The pictured notification keeps appearing and I have to keep dismissing it; it's annoying. Is there a way to make it go away permanently while leaving Do Not Disturb on? Or am I cursed to see it forever?

View attachment 776443

I hate that bar too, and here’s what I did a few minutes ago and so far so good… I have an iPhone 6 Plus on iOS 12… I went to settings, notifications, and then under “show previews “ I chose never. This may delete all notifications coming up ever but that’s OK with me, I can manage my phone without them. Hope this works and helps you!
[doublepost=1538250545][/doublepost]P.S. I had to clear the very last notification before it went away for good, by sliding it off the lock screen and hitting clear.
 

mpavilion

macrumors 6502a
Aug 4, 2014
923
534
0
SFV, CA, USA
That's just it, though, I still want notifications, just not when the screen is off. DND is perfect for that, but now it pops up this annoying banner.
How often do you restart your iPad, though? If you dismiss the banner just once (as suggested above), it will be gone until the next time you restart (since you keep DND activated all the time).
[doublepost=1538320520][/doublepost]
I hate that bar too, and here’s what I did a few minutes ago and so far so good… I have an iPhone 6 Plus on iOS 12… I went to settings, notifications, and then under “show previews “ I chose never. This may delete all notifications coming up ever but that’s OK with me, I can manage my phone without them. Hope this works and helps you!
[doublepost=1538250545][/doublepost]P.S. I had to clear the very last notification before it went away for good, by sliding it off the lock screen and hitting clear.
I believe disabling “Show Previews” just keeps the lockscreen notifications from showing a few lines of each email, or the contents of each text message, etc.? To actually keep notifications from appearing in the lockscreen, you’d have to go into the notification settings for each app...
 

lax28

macrumors 6502
Sep 28, 2014
266
143
0
New Jersey
I don’t care for it either, as I do similar with my multiple devices, but I can see and understand why this new pop up is here and the value that it can hold for many people who temporarily use DND and forget to end it, or mistakenly turn on DND.

Obviously the good for the many far out weights the fact some of us don’t “like” it. If it had been there from day one you wouldn’t know any different.

Since we can’t change it I would recommend not letting minor little things like this get your panties or boxers in a bunch. I just find it not worth the extra stress and aggravation in my life.

Use the breath app, calm down and hakuna matata
 

GreyOS

macrumors 68040
Apr 12, 2012
3,265
1,550
0
I don’t care for it either, as I do similar with my multiple devices, but I can see and understand why this new pop up is here and the value that it can hold for many people who temporarily use DND and forget to end it, or mistakenly turn on DND.

Obviously the good for the many far out weights the fact some of us don’t “like” it. If it had been there from day one you wouldn’t know any different.

Since we can’t change it I would recommend not letting minor little things like this get your panties or boxers in a bunch. I just find it not worth the extra stress and aggravation in my life.

Use the breath app, calm down and hakuna matata
If you don’t like it, report it to Apple, then relax.
 

ectospheno

macrumors regular
Sep 19, 2005
209
220
0
The reason we are stuck with this is because of all the people who were too dense to realize their phone was in DnD and were complaining everywhere they could that their phone was broken. Allowing you to turn off the notification sticks Apple with the same problem. So I'm not expecting them to allow you to blanket disable it.
 
  • Like
Reactions: chabig

TheSkywalker77

macrumors 65816
Sep 9, 2017
1,421
811
0
Florida
The only viable way to remove it is to just swipe the notification away as you would normally do. From what I've seen that usually does it until do not disturb is turned back on. I really hope Apple will add an option to disable this in the future.

Maybe in iOS 12.1 Beta 2. ;)