Has anyone found a fix to the dropping wifi on SL

Discussion in 'macOS' started by Marcus263, Sep 7, 2009.

  1. Marcus263 macrumors regular

    Joined:
    Jun 16, 2009
    #1
    There are loads of posts all over the web regarding SL dropping wifi connection here and there, does anyone have a fix?
     
  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #2
    Not experiencing it here. Why not try replying to some of those threads?
     
  3. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #3
    Nope, the problem is extremely annoying. I've seen it on MANY machines now.

    Here's to 10.6.1...
     
  4. Marcus263 thread starter macrumors regular

    Joined:
    Jun 16, 2009
    #4
    Yeah I have but it's not yielding any results. Everyone is clueless right now.

    Zig, there is no way I am going to be able to put up with it until 10.6.1 comes out, that could be months away. Has Apple even acknowledged the problem?

    EDIT: I changed my Location from Automatic to a newly created one called "HOME", now it is forced to stay on this connection even if there maybe a better signal else where.
     
  5. PJohnson macrumors member

    Joined:
    Jan 30, 2008
    #5
    I did this also, and I deleted the preference files to force new ones to be created...

    No success... still drops.

    The only thing I learned is that it is one specific wifi network nearby causing the problem. My MBP sees it and tries to connect, and drops my home wifi.

    Anybody got help?
     
  6. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #6
    If I remember, Apple fixed this issue in Mac OS X 10.6.2 or they released a separate Airport update to fix the bug. I had this issue, but it has been resolved for me.
     
  7. PJohnson macrumors member

    Joined:
    Jan 30, 2008
    #7
    I'm at 10.6.3 and I've downloaded the latest Airport client...
     
  8. After G macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
    #8
    What's the order of the networks in

    System Preferences > Network > Airport > Advanced?

    Maybe reorder them, or remove the ones you don't need?
     

    Attached Files:

  9. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #9
    Yep but it requires you to follow instructions exactly:

    1. Open System Preferences->Network pane and turn off Airport completely!

    2. Navigate to the folder to /YourHardDrive/Library/Preferences/SystemConfiguration/ and remove all the files in it.

    3. REBOOT Immediately!!! This will rebuild those files.

    4. Turn the wireless back on in system Preferences=>Network pane and rejoin the wireless network.

    If this doesn't fix it then Reset Your PRAM or Reset the SMC.

    Does OS X still see the wireless card? to see hold down the 'option' key while clicking on the Black Apple in the top left hand corner to launch "System Profiler" to see it if OS x still see the wireless card.

    Good Luck.
     
  10. PJohnson macrumors member

    Joined:
    Jan 30, 2008
    #10
    Only my home network shows in the box. I never establish a connection with the offending network, it just seems to be able to 'distract' my Mac long enough to drop the connection.

    Phil
     
  11. PJohnson macrumors member

    Joined:
    Jan 30, 2008
    #11
    Still no success.
    Resetting the PRAM and SMC did not help.

    I have observed the moment when the network drops and it is clearly tied to when Airport looks for other networks and sees this one particular network. When it drops it will even cause iStumbler to crash.

    The Airport card has always been visible in System Profiler.

    My working theory is this:
    My DSL modem/Wifi router is about 3 years old and does not support 802.11(n). My MBP is not quite that old (but new to me) and does support 802.11(n). The wonderful Apple engineers of SL decided that Airport under SL should ALWAYS search for and try to connect at the best possible speed, even if the computer is already connected to wireless network. So, when Airport sees this other network (which I presume to be 802.11(n) ), it tries to connect to it because it 's faster and drops the current connection.

    If I could stop Airport from searching or tell it to ignore certain networks (or all other networks), the behavior would stop.

    Still hoping for a solution...

    Phil
     

Share This Page