Has anyone found a real fix for Wifi issues after 8.1.x update?

Discussion in 'iPad Tips, Help and Troubleshooting' started by Arcus, Dec 27, 2014.

  1. Arcus macrumors 6502a

    Joined:
    Dec 28, 2004
    Location:
    of my hand will get me slapped.
    #1
    iPad 3 running great for years on 7.x . Updated to 8 and have had nothing bu problems with the wifi connection. After 8.1.2 the ipad prompts me for my wifi password but tells me it is wrong.

    Disabling wifi security does not solve the problem. I have 2 Netgear WNR2000v3s and one generic FIOS router.

    Just got back from the Apple store after an appointment with the "genius". He told me to unplug my router for 10 mins to make sure they forget the iPad and then rest network settings then it will join.

    Knowing that I had already done this after reading for hours I treid to get him to explain to me in anything other than analogy to locks and keys and other garbage he insisted that he has never had someone come back after doing this. Of course this didnt work as I already did a full restore, stood on my head, rebooted , flushed the cache , juggled oranges and all other manners of things to get this to work.

    I has tried to join a store a few doors down from the apple store but he said "oh yea that wifi is broken, I use it sometimes". Huh??

    Came home , did what he said to all three routers , didnt work.

    I would agree that there does not appear to be a problem with the hardwre but something in 8.x broke wifi and I suspect the fact that it wont join anything but an apple airport is no coincidence. Wont work at starbucks, friends house, my work. No where where there is not an apple wifi router.

    So now I have an iPad 3 brick.

    Has anyone ever gotten their iPad to work who has been in my situation?

    Im tempted to just sell it to Gazelle and let them fight with apple.
     
  2. rigormortis, Dec 28, 2014
    Last edited: Dec 28, 2014

    rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #2
    if you enter a wifi password, and it won't work, one of the reasons why this happens is a math error between the iPad and the wireless router. i have actually seen this happen with kindle keyboads and airport extremes.

    go to https://www.wireshark.org/tools/wpa-psk.html

    this website runs on your browser, it does not save anything you enter it on your computer or their computer.

    enter your SSID , for example , "netgear"
    enter your password, for example , "abcd1234"

    click on generate PSK

    It will spit out the actual preshaed key that is used to connect your iPad to your wireless router, for example "124673b3971477384bcaf382ea050c300d9a669603f6c49efd19cfc9008f7dba"

    forget your wireless network on your iPad or maybe go as far as resseting network settings. paste the 63 character PSK (504 bit key) you got from wireshark , instead of your regular password.

    it should connect.

    if it fails then you probably need to DFU or restore your iPad with itunes or ask apple for help.

    when you try to join a wireless network based on WPA or WPA 2 security , you do not simply just give the wireless router your password. all passwords are calculated into a formula that produces a 504 bit key. and it is that actual 504 bit key that authenticates your iPad to the wifi network

    this pre shared key is not the actual key that is used to encrypt wifi traffic , that is a separate rolling key


    its more likely your iPad is maybe defective or it needs to be restored with itunes, but simply trying the actual psk is easier as a trouble shooting step, then erasing your gadget or waiting for a fix, or asking apple to replace your iPad, or selling it
     
  3. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #3
    if it doest work at starbucks, which is not even an encrypted network then try one of the following, until it is fixed



    back up and restore from itunes. , this requires find my iPhone to be turned off
    http://support.apple.com/en-us/HT201252

    perform a DFU reset
    http://www.iphonehacks.com/put-iphone-in-dfu-mode

    click on general ,reset, reset all settings

    click on general , reset, reset all network settings


    lastly try to set it up as a new iPad


    make sure you back it up and go as far as clicking on transfer purchases , and back up photos and videos from camera roll before erasing the iPad


    if none of this works. then go to the genius bar, and ask them what to do before
    spending the $299 repair fee or selling it
     
  4. IrishVixen, Dec 28, 2014
    Last edited: Dec 28, 2014

    IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #4
    Since you're having issues with the password, I'd suggest taking a backup tho preserve your data, setting up as new, and NOT restoring immediately from backup. If it still has that issue when it's completely fresh, then it may be a hardware problem. If not, I'd consider just syncing what you need, rather than restoring from backup.

    But if the problem is still there on a completely clean restore, it's possible there's a hardware failure involved. Still, I tend to think with all the other WiFi issues we've had with 8.x, I'd be surprised if it wasn't a firmware problem.
     
  5. Arcus thread starter macrumors 6502a

    Joined:
    Dec 28, 2004
    Location:
    of my hand will get me slapped.
    #5
    Thanks all for your replies.

    I have done everything from forgetting the network to resetting settings to wiping and restoring , twice.
     
  6. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #6
    if generating the psk in my earlier post didn't work, then i think the iPad needs to be replaced

    using the PSK instead of the passphrase rules out wifi incompatibles between wifi equipment
     
  7. Arcus thread starter macrumors 6502a

    Joined:
    Dec 28, 2004
    Location:
    of my hand will get me slapped.
    #7
    Thanks Rigor for the suggestion. I had tried turning off all security and it would not join. Brought is to work today and it wont join my wifi here either.

    Apple seems to dismiss the issue since it joins their WiFi just fine. This started with the 8.1.1 update. 8.1.1 it would drop off and not see any routers at all. Not with 8.1.2 it always sees wifi but it can never join a non apple router. It had been working perfectly.
     

Share This Page