Has anyone had this Wi-Fi/internet issue in Sierra?

Discussion in 'macOS Sierra (10.12)' started by ScottButler, Dec 5, 2016.

  1. ScottButler, Dec 5, 2016
    Last edited: Dec 5, 2016

    ScottButler macrumors member

    ScottButler

    Joined:
    Sep 16, 2016
    Location:
    Sunderland, UK
    #1
    I have a 5K iMac from 2014 and since the update to Sierra I've been having intermittent internet issues. Maybe once every 2 hours the blue progress bar in Safari will just stick about a quarter of the way through, for up to 15 minutes, and then will just load like nothing happened. All other internet based apps, Apple Music in iTunes etc, are also affected.

    All my other devices are unaffected when this happens suggesting the internet connection/router (AirPort Extreme) is operating normally.

    I've tried a hardware test which came back without issue, deleted Network preferences and I have reinstalled Sierra from recovery utilities, and the issue still remains as intermittent as before.

    The only thing I haven't tried yet is a full clean install, but obviously this would be a last resort.

    Has anyone faced a similar issue and got it resolved?
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    There could be a number of things causing the problem. I would suggest:

    1) Check the system uptime (open Terminal and type in uptime). Often a larger time since last shutdown (7+ days) can compound problems similar to what you're having. So best to shut down with reopen windows when logging back in disabled/unticked, as this can reopen background processes.

    2) Also ensure the wireless encryption on the router is set to WPA2-PSK/WPA2-AES only (no mixed mode), as this encryption works best on Apple devices.

    3) Make sure the OS is fully up-to-date as well.

    Sorry the troubleshooting steps above are a little basic but they do often fix the problem - hopefully it might be a simple fix. :)
     

Share This Page