Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors 6502
Original poster
Feb 12, 2009
St Augustine, FL

I am considering purchasing a copy of Rosetta Stone Latin American Spanish Version 3 from a friend and I am wondering if it will work with Lion.

Rosetta Stone says nothing is supported on Lion yet so I don't know what to think.

Has anyone tried it?

Thank you.


macrumors member
Jan 3, 2009
Right, but no one has added information about version 3 which is what I am looking at.


Same problem... I'm in the middle of trying to learn spanish, and I really want to install lion, but if V3 of Rosetta Stone isn't supported, I will have to wait. That ****'s expensive.


macrumors newbie
Jul 21, 2011
Rosetta 3.4.5 is working fine, except I'm having problems getting my headset to work. I'm able to use it with the built-in mic and speaker, but I can't pass the microphone check when using my Logitech ClearChat USB. The dialog box grays out upon asking me to speak "1,2,3,4,5". In the Sound preferences panel the headset detects fine.

Are you guys having luck with your headsets?


macrumors regular
Oct 14, 2007
Called Rosetta Stone and they said version 3 should work.

I installed Lion, and they were correct. No problems.


macrumors newbie
Jul 23, 2011
Rosetta Stone 3 Works on Lion BUT no Audio/Mic

Rosetta Stone 3 works on LION on my system but there are no recognized microphones. When the Microphone setup page is displayed, the list of available microphone input devices is empty and the refresh button does nothing to change that.

However, I have two recognized and working microphones on this iMac. One is the regular internal iMac microphone and the other is the Rosetta Stone supplied headset with microphone. They both work, they are both recognized by the System Preferences box but they DO NOT show up in Rosetta Stone.


macrumors newbie
Jul 23, 2011
I'm having the same issue with Rosetta Stone not recognizing input devices in Lion. Line-in and built in microphone both work in all other apps I've tried. I did some searching, tried the Line-in and Soundflower combination to see if Rosetta would recognize those, but no dice.

Anyone gotten their input devices to show up in Rosetta?


macrumors member
Apr 10, 2011
I just installed Lion. I am having the same issues with rosetta stone detecting no microphone. When i go into preferences within rosetta stone the drop down box for me to select a mic is completely empty. I have tried using sound flower and nothing seems to work. Anyone called rosetta stone about this? I really hope there is a fix for this as i don't want to have to downgrade to snow leopard but will have no choice if i can't find a fix.


macrumors newbie
Jul 23, 2011
I emailed Rosetta, and their reply was to upgrade to v4 from 3.4.5, but the input devices still would not show. I've tried everything I can think of to try to get the settings panel to recognize any input devices, but no luck yet.

My solution finally was to just downgrade back to 3.4.5 and turn off speech recognition, which really sucks. I just pause on the screens where the recognition would have taken place and practice the speech on my own.

It appears Rosetta is aware of the issue though, according to the sentence at the bottom of this page


macrumors 65816
Nov 17, 2010
They seem to have 1-2 guys working on the app at any given time. Releases are too few and far in-between. I hope an update optimizes the program (it sits at 6-10% at idle) and support the new lion full screen API.


macrumors newbie
Jul 26, 2011
Rosetta Stone Fix

Some of you are discussing a problem where your microphones are no longer visible in the list of microphones after upgrading to OS 10.7. At least in my case I was able to upgrade to the most current version of rosetta stone and my microphones are now listed and work fine. I was at V3.4.5 of the Rosetta Stone, here is the link :

Just download and install the new version.

iMac V10.7
  • Like
Reactions: americantigres


macrumors member
Apr 27, 2011
Montréal, PQ.
What is Rosetta

From Wikipedia

Rosetta is a lightweight dynamic translator for Mac OS X distributed by Apple. It enabled applications compiled for the PowerPC family of processors to run on Apple systems that use Intel processors. Rosetta was based on Transitive Corporation's QuickTransit technology,[1] and was a key part of Apple's strategy for the transition of their Macintosh line from PowerPC to Intel processors as it enables pre-existing Mac OS X software to run on the new platform without modification.

Rosetta has no GUI, leading Apple to describe Rosetta as "the most amazing software you'll never see".[2]

The name is likely a reference to the Rosetta Stone, the discovery of which made it possible to comprehend and translate Egyptian hieroglyphs.

In Mac OS X v10.6 ("Snow Leopard"), Rosetta is not included by default but there is an option in the installer for the user to include it or it could be automatically downloaded by the system if needed at a later time.

Mac OS X v10.7 ("Lion") does not include or support Rosetta. Therefore, Lion drops support for all PowerPC applications.[3]



macrumors newbie
Aug 6, 2011
Rosetta Stone- Fatal Program Error with Lion

I recently installed Lion on MacBook Pro 2.4 GH Intel i5. Have been having problems with Lion but worst was with Rosetta Stone V4 Vietnamese. First few times everything worked fine. Last night I was using Rosetta and walked away for computer for about 15 minutes and when I came back had black screen. It was like my computer was toast. Wouldn't refresh, black screen, and wouldn't reboot. After about 3 attempts of holding start button, the system slowly came up. When it came up I got the message "Fatal Program Error". I am still in the process of finding out what caused that. My advice is don't leave the program open and walk away from it. Close it.
Now, on to a thread to find out why Mail won't close and can't shutdown normally...


macrumors member
Jun 1, 2011
United Kingdom
I had problems with the microphone too but I found if you go into system preferences -> sound -> click on internal mic and set the volume to half, it sorted out the mic problems...


macrumors newbie
Jul 11, 2008
My version was 3.3.7

After a clean install of Lion, I had to reinstall my programs and installed Rosetta Stone 3.3.7.

Microphones didn't show up.

I updated to 3.4.5, restarted, and now the microphones are showing.


macrumors G3
Mar 26, 2008
West Suburban Boston Ma
From Wikipedia

Rosetta is a lightweight dynamic translator for Mac OS X distributed by Apple. It enabled applica...

While this is correct, the thread is about Rosetta Stone which is an application written to help people learn other languages. The OSx Rosetta extension has nothing to do with the Rosetta Stone user application.

Matthew Lococo

macrumors newbie
Aug 26, 2011
Rosetta stone 3 work around for usb headset

Hi everyone,

This is a convoluted one so hold on to your seats.

You need sound flower and LineIn for this to keep Rosetta Stone from changing the Sample Rate of your USB Headset to 16kHz. In LineIn make the input from field your USB Microphone then make the output to Sound Flower 2ch then select Pass Thru. In both the Sound Flower and USB setting in the Utility Audio MIDI setup make sure that everything is 44.1kHz Make sure Rosetta stone is pointed to Sound Flower 2ch.

You sound output can remain the USB Headset. The software bug is Rosetta Stone changing the input to 16kHz and then Rosetta Stone does nothing after that. Sound flower and LineIn run interference to keep it from doing that

Worked for me!
good luck!
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.