Has anyone tried to downgrade back to 2.x yet? (from 3.0 beta)

Discussion in 'iPhone' started by skoops, Mar 18, 2009.

  1. skoops macrumors regular

    Joined:
    Jan 8, 2007
    #1
    Hey folks;

    I can live with every single bug of the new 3.0 firmware - but there's ONE thing, that really bothers me :)

    Since upgrading to 3.0 my iphone won't recognize the universal dock or my car hi-fi system. (both are connected via the standard 30-pin apple dock connector) - so now I'm forced to listen to the crappy radio stations while driving to work.

    Has anyone tried downgrading? (I know it will probably require a JB-2.2.1 image and DFU mode - I just want to know if anyone did this already.

    Thanks in advance

    skoops
     
  2. wil49 macrumors member

    Joined:
    Mar 18, 2009
    Location:
    Chester, UK
    #2
    If you are a developer it explains this in the documentation.
     
  3. skoops thread starter macrumors regular

    Joined:
    Jan 8, 2007
    #3
    the documentation says it can't be done - but I don't entierly believe in documentations ;)
     
  4. anjinha macrumors 604

    anjinha

    Joined:
    Oct 21, 2006
    Location:
    San Francisco, CA
  5. arubinst macrumors 6502

    Joined:
    May 26, 2008
    Location:
    Lausanne - Switzerland
    #5
    Have you tried this yourself?
     
  6. anjinha macrumors 604

    anjinha

    Joined:
    Oct 21, 2006
    Location:
    San Francisco, CA
    #6
    Yes.
     
  7. arubinst macrumors 6502

    Joined:
    May 26, 2008
    Location:
    Lausanne - Switzerland
    #7
    With the 3.0?

    This is good news. It's all I needed to know to try the beta on my iPhone.
     
  8. Bailey macrumors newbie

    Bailey

    Joined:
    Feb 13, 2004
    Location:
    London, UK
    #8
    I completely failed downgrading last night (Exchange doesn't work properly on 3.0 on my server), and thought I was stuck with 3.0

    If it is possible to go back to 2.2.1, any assistance would be much appreciated!
     
  9. LinMac macrumors 65816

    Joined:
    Oct 28, 2007
    #9
    Try to follow the 2.2.1 to 2.2 etc downgrade instructions. That might do the job for a 3.0 to 2.2.1 downgrade.
     
  10. Bailey macrumors newbie

    Bailey

    Joined:
    Feb 13, 2004
    Location:
    London, UK
    #10
    I tried this last night, and couldn't get it to work. Everytime, it failed on the baseband portion, and restarting the phone in DFU mode didn't appear to work. The only way I could get back to a functional phone was to reinstall 3.0.
     
  11. Bailey macrumors newbie

    Bailey

    Joined:
    Feb 13, 2004
    Location:
    London, UK
    #12
    Gee, I hadn't done that already. :)

    My iPhone went into DFU mode, but I still couldn't get back down to 2.2.1.
     
  12. lOUDsCREAMEr macrumors regular

    lOUDsCREAMEr

    Joined:
    Mar 30, 2006
    Location:
    Safari desert
    #13
    NO, I'VE TRIED IT
     
  13. koobcamuk macrumors 68040

    koobcamuk

    Joined:
    Oct 23, 2006
    #14
    I'm not going to try it because I don't need to right now.
     
  14. arubinst macrumors 6502

    Joined:
    May 26, 2008
    Location:
    Lausanne - Switzerland
    #15
    Don't you need a pwaned 2.2.1 to be able to downgrade?

    That's what I read on some thread, I think...
     
  15. Pared macrumors 65816

    Joined:
    Oct 19, 2007
    #16
    Gotta love the vague "yes" and "it can be done" posts.

    Explanations as to HOW it can be done, specifics, would be nice. I'm not in the situation where I need it but keeping the OP hanging by a string without telling him how is pointless.
     
  16. lukmei macrumors newbie

    Joined:
    Mar 18, 2009
  17. Mikey B macrumors 65816

    Mikey B

    Joined:
    Jan 4, 2008
    Location:
    the island
    #18
    Though I haven't tried, I'm willing to bet that it won't work. I'm pretty certain that the 3.0.ipsw upgrades the baseband thus making it impossible to downgrade. I don't know of any way to downgrade basebands, but it could be possible.

    If you want to be able to use 3.0 and go back to 2.2.1, you'll probably have to wait until the Dev Team comes out with a way to pwn 3.0 so the baseband isn't upgraded.

    I wish it would work, I'm about to install 3.0 and I'm a little afraid the bugs will be too much to bear. I need my iPhone for my "real" job as well as development. We'll see...
     
  18. coolcom macrumors newbie

    Joined:
    Mar 18, 2009
    #19
    Last night I forgot to get my UDID before flashing to the 3.0 beta. I did not know getting the UDID was as easy as going into system profiler -> USB -> iPhone -> copy the serial number (this serial number is the UDID).

    I thought the only way was through iTunes and it was not activating my device since I had not registered it with ADC. Anyway, long story short, I put the phone into DFU mode and tried restoring to a previous FW and i could NOT get it to work (with 2.2.1, 2.2, or 2.0). It would fail each time mid-way with an "unknown error."

    Futhermore, you CAN NOT get out of DFU mode without a successful restore. I had to restore to the 3.0 beta FW to get out of DFU mode.

    Anyway, it's all working now and I'm very happy!
     
  19. lukmei macrumors newbie

    Joined:
    Mar 18, 2009
    #20
    ok, so there is no way back.
    Do I have to re-activate an already activated iPhone 3G after the update to 3.0 (from 2.2.1)?? Or is this only necessary for syncing with iTunes??
     
  20. aames macrumors newbie

    Joined:
    Sep 16, 2008
    #21
    This is necessary for the phone to perform anything other than emergency calling (and I mean anything)
     
  21. PaThKu macrumors member

    Joined:
    Oct 28, 2007
    #22
    For all of you that claim you can downgrade, do you have 3Gs? I read online somewhere that 3Gs cannot be downgraded, but the 1st gen iPhones can. I already tried DFU with my 3G, I can't downgrade it either.

    Looks like I'll just have to start reporting those bugs! :D
     
  22. OriginalMasta macrumors member

    Joined:
    Mar 18, 2009
    #23
    Yes, mine is 16GB 3G model. and yes, it CAN BE DOWNGRADED. But the baseband is no longer 2.28.00 after 3.0 beta
     
  23. anjinha macrumors 604

    anjinha

    Joined:
    Oct 21, 2006
    Location:
    San Francisco, CA
    #24
    I have successfully downgraded from 3.0 to 2.2.1

     

Share This Page