Has anyone's computer ever acted like the command key was stuck?

Discussion in 'MacBook Pro' started by secretpact, Mar 12, 2008.

  1. secretpact macrumors 6502

    Joined:
    May 24, 2007
    #1
    I've done a search on google and these forums and have only found a few results on google.

    http://www.mac-help.com/forums/showthread.php?t=4210
    http://forums.macosxhints.com/archive/index.php/t 20 3C/t-74630.html
    http://www.macusersforum.com/lofiversion/index.php?t18345.html
    (I think the last two guys are the same)

    Has anyone else had this problem? Cause it just happened to me twice within the last couple of days on my new MBP, and I have a MacBook that I bought May last year and I've encountered it once or twice with that one too. A restart fixes the problem for me (It didn't for one user on the forums in the links), but it's pretty annoying when you're writing a paper and all of a sudden typing h hides Word. :confused:

    Here are my symptoms:
    Clicking spotlight - constantly get the system alert noise
    Clicking an app on the Dock: Opens the applications folder and selects the application corresponding to the dock.
    Selecting files: Acts as if command key is held down.
    Moving windows: Acts as if command key is held down (you can move windows in the background, they will not become active)
    "Are you sure you want to shutdown" screen - constant system alert beeps.
     
  2. mexicankiwi macrumors newbie

    Joined:
    May 14, 2010
    #2
    Same problem - command key locked -HELP!!

    Did your computer fix itself on restart? Mine doesnt and its got me beat... Do you have any other suggestions for unlocking the command key?

    Thanks


     
  3. mexicankiwi macrumors newbie

    Joined:
    May 14, 2010
    #3
    Command Key Locked

    Hi there,

    I'm new to this site so not quite sure how to use it yet.

    I have the same problem of my apple command key being "locked". Cant use spotlight - system alert, Cant type on the keyboard - it just activates the relevant quick key. When I try to select documents from finder it just keeps selecting them like I'm holding the apple key down. Cant open Keyboard Viewer for some reason.

    I tried restarting holding down the shift ket but no joy.

    Any ideas??? I'm seriously confused.
    Thanks
     
  4. Thelmajg macrumors newbie

    Joined:
    Jul 10, 2010
    #4
    I took my keys off my laptop, then reattached. Restarted the laptop and it worked on and off. I just zapped the PRAM and it seems better.
     

Share This Page