Has Apple disabled iMessage for 4,1 Mac Pro under 10.11?

Zorn

macrumors 65816
Original poster
Feb 14, 2006
1,048
610
Ohio
For the past 2 days now, the Messages.app hasn't been working for me. It always worked flawlessly on the betas of El Cap. Now, when I try to open Messages on my Mac Pro, I get a window asking me to sign in to my Apple ID. When I do, it just spins around then gives a random error about iMessage activation error. Anyone experienced anything like this? I'm completely lost.
 

h9826790

macrumors G5
Apr 3, 2014
14,245
6,849
Hong Kong
It's works well on GM and 10.11.1 beta. I am using 4,1 but I skip the official 10.11, so I can't really tell. However, I don't think there is a hard limit to stop the 4,1 using iMessage. May be it's just a coincidence.
 

BillyBobBongo

macrumors 68030
Jun 21, 2007
2,509
1,045
On The Interweb Thingy!
For the past 2 days now, the Messages.app hasn't been working for me. It always worked flawlessly on the betas of El Cap. Now, when I try to open Messages on my Mac Pro, I get a window asking me to sign in to my Apple ID. When I do, it just spins around then gives a random error about iMessage activation error. Anyone experienced anything like this? I'm completely lost.
Yeah, I had this problem. I also had it on my MacBook Air too, suggesting that it's more an issue with El Capitan than with the Mac Pro.

I tried many ideas out to fix this particular error, but in the end these two ways seemed to work:

1. Sign out of iCloud, Messages and FaceTime (in that order) and then sign back in to them (in that order) - This got the MacBook Air back up and running.
2. Sign out of iCloud and delete all the iCloud files in Application Support (/Users/NAME/Library/Application Support/iCloud) - I signed back in and it all fired up correctly on my Mac Pro.

Failing that. Here's an forum post on the Apple Discussion forums that has some other options - https://discussions.apple.com/thread/5207594?start=0&tstart=0

Best of luck!
 

Zorn

macrumors 65816
Original poster
Feb 14, 2006
1,048
610
Ohio
Trying it in the guest account works, seems something went wrong with my account. Is the best course of action to just delete my account and make a new one?
 

Zorn

macrumors 65816
Original poster
Feb 14, 2006
1,048
610
Ohio
Well, I tried making a new account, and Messages.app still doesn't work at all. It seems to only work when logged into a guest account, not really sure what to make of that.
 

superdx

macrumors regular
Jul 23, 2009
130
11
I had the same problem, I solved it by logging in with one of the iCloud accounts associated with my Apple ID and was able to successfully log in. Once there I was able to switch the sending email address to my primary account and all my chat history was still there. As it works fine, I haven't tried logging out from the 2nd iCloud account back to primary.

This problem only happened on my MP4,1 after the El Capitan upgrade, none of my other machines had this problem.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.