Has my sound card blown?

Discussion in 'Mac Basics and Help' started by Helikaon, May 5, 2009.

  1. Helikaon macrumors newbie

    Joined:
    May 5, 2009
    #1
    I have a problem with sound playback on 4 month old mac pro. I have not upgraded the sound card, it is the mac pro standard one.

    I am suddenly experiencing no playback at all from itunes or safari or anything.

    I tested my external speakers and it is not them, they work fine.

    I have done system preferences > sound > made sure line out is selected.

    When the mac starts up i still get a 'dong' sound that comes out the internal speakers, and also i do get playback from the internal speakers when internal speakers is selected in sound preferences.

    My question really is how do i know if my sound card has blown, and if the internal speakers ARE working, does this mean the sound card has not blown?
     
  2. Cave Man macrumors 604

    Cave Man

    #2
    Reset your PRAM and see if that resolves it. My Mini does this all the time and the reset resolves it. Weird, but persistent problem.
     
  3. surflordca macrumors 6502a

    surflordca

    Joined:
    Nov 16, 2007
    Location:
    Ontario, Canada
    #3
    First i take it you checked that they are not muted? Also if you have either Parallels or VMware running they could be taking over your sound settings. Close them and see if the sound comes back to the Mac. I run both, Parallels and VMware and they both take over the sound from the Mac Pro that I have.
     
  4. Cave Man macrumors 604

    Cave Man

    #4
    If that were the case then the external speakers would not have worked, either.
     
  5. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    Question: When you have the external speakers plugged in and Line Out set, and you use the keyboard to adjust the volume level, does the floating volume display show a circle with a line through it indicating that the volume can't be adjusted?

    If not, then a PRAM/PMU reset is your best bet. You could also try booting from the OS install disc and seeing if you get sound through the external speakers from there, to make sure it's not software.

    If you DO get that icon, it means that your Mac Pro thinks that an optical miniplug is inserted rather than an analog one (I'm assuming here that you're using an analog 1/8" plug). If so, it's probably caused by the little switch inside the jack getting stuck--it can and does happen. It can probably be fixed by plugging and unplugging something repeatedly into the jack to knock it loose. Alternately you can apparently poke it carefully with a pin or straightened paperclip, but I'd be VERY careful doing that unless you can see the switch inside with a flashlight.

    The good news is if it actually is broken (which frankly seems to be VERY uncommon in situations like this) and the computer is only 4 months old, it's covered under warranty.
     

Share This Page