Hash in Parallels using UK wireless keyboard

Discussion in 'Windows, Linux & Others on the Mac' started by quaffa, Sep 5, 2011.

  1. quaffa macrumors member

    Joined:
    Aug 5, 2011
    Location:
    Manchester, UK
    #1
    Hi,

    Does anyone know an easy way of getting a UK Apple Wireless keyboard to type the hash symbol (#) when working in Windows 7 under Parallels please?

    The only way I can figure out so far, (without changing the keyboard map or something equally drastic), is to select, copy & paste from the Windows Character Map, but it is a bit tiresome.

    Is there an easier way?

    *I do know that alt+3 types the hash in Mac OS X, even thought it's not on the keyboard, but it doesn't do that in Windows.
     
  2. adrianparallels macrumors newbie

    adrianparallels

    Joined:
    Sep 16, 2010
    #2
    Hey this is a member of the Parallels Support team. Please see this Knowledge Base article here for more information on keyboard layouts in Parallels Desktop 7 for Mac: http://kb.parallels.com/en/111674
     
  3. quaffa thread starter macrumors member

    Joined:
    Aug 5, 2011
    Location:
    Manchester, UK
    #3
    Hmmm. Thanks for that.

    I appreciate that you're trying to flog me Parallels 7, which is fair enough, but can you clarify that this is a feature that is definitely new to version 7, please?

    I ask because there is a similar option through the Win7 Control Panel under Parallels 6, but it doesn't enable the hash symbol [alt+3] in Win7 apps when using the UK Apple Wireless keyboard.
     
  4. metahome macrumors newbie

    Joined:
    Sep 26, 2011
    #4
    I can't speak for running Win7 in Parallels 7 as I am running Windows XP in Parallels 7 on a MacBook Air running Lion with a British keyboard.

    The Windows keyboard map I am using is:
    English [United Kingdom] - United Kingdom [Apple] - Parallels

    See the regional and languages control panel, see the language tab and click details. There is an equivalent under Win7, but I don't have a system handy to check what it is.

    With this keyboard map you can enter the hash symbol by pressing the right-hand cmd, the right-hand alt and 3. If you want to enter a Euro symbol, do the same thing with the 2 key.

    I hope the same thing might work for Win7 - perhaps someone can try it and confirm?
     
  5. quaffa thread starter macrumors member

    Joined:
    Aug 5, 2011
    Location:
    Manchester, UK
    #5
    Thanks metahome!

    My keyboard setup was slightly different in that my keyboard was showing as just United Kingdom [Apple]; there was no option to add the '-Parallels' bit. I'm still running Parallels 6, so maybe that's why.

    But, nevertheless, following your description of what keys you press, I tried the same combination and got the same result. :)

    (I'd just been using the left alt & cmd keys before.)

    Thanks again. Problem solved.
     
  6. leprechaun macrumors newbie

    Joined:
    Feb 25, 2012
    #6
    A working solution to iMac keyboard configuration

    My set up is iMac with OSX Lion and Parallels, with XP Professional as my Windows OS. I am using a 2012 small aluminium wireless keyboard.

    I had the problem when in Word and Macromedia Studio 2004's Dreamweaver running with Parallels that the "£" sign would not display (I was getting "#"), the @ symbol and the "" marks were transposed and the € would not display.

    Adjusting the Regional Settings in the Windows Control Panel had no effect.

    Eventually I was guided by the Parallels Support Team (Syed Kareem) to this link:
    http://www.parkernet.com/applepro/
    where I obtained a total solution for free. The only additional information I would add is that having added the Extended UK Apple keyboard configuration he talks about, do remove all the other keyboard capabilities already showing otherwise the solution does not seem to work. Well done to parkernet.com :)
     
  7. quaffa thread starter macrumors member

    Joined:
    Aug 5, 2011
    Location:
    Manchester, UK
    #7
    Yes, thanks for that, Mr Parker(?).

    However, as I say above, I have already had my problem solved by metahome, and I simply use the right-hand cmd+alt keys to type the # symbol and the € symbol under Windows Parallels, whereas I use the left-hand ones under OS X.

    No need to install anything extra at all.
     

Share This Page