Haswell 13" rMBP + Boot Camp + Win 7 = No keyboard & mouse

Discussion in 'Windows, Linux & Others on the Mac' started by flr, Oct 24, 2013.

  1. flr macrumors member

    Joined:
    Sep 30, 2013
    #1
    The new 13" Retina MacBook Pro 2.6GHz is just awesome! I've received mine today. But installing Windows 7 64-bit with Boot Camp isn't possible because the keyboard and mouse aren't working. I've downloaded the "Support software" and used the Boot Camp Assistante to create the install USB drive. Adding a USB keyboard and mouse doesn't solve the problem. There is probably something wrong with the USB 3.0 support. The same problem occured when the MacBook Air was introduced in june 2013. Has anybody solved the problem or should I wait for Apple to update the "Support software"?
     
  2. faslane macrumors newbie

    Joined:
    Nov 12, 2006
    #2
    Same here, NO Windows 7 on new 13" Haswell Model

    I just got mine today on the 26th. 13" rMBP i-5 4/128 and while Win 7 installed correctly, I can't use the trackpad, keyboard, power, usb etc. It'll boot but no response from anything afterwards. I'm sure there will be an update soon though. Same thing happened on some of the Airs an a week later all good but it seems sucky Apple didn't address this first before release. :confused:
     
  3. ganomi macrumors newbie

    Joined:
    Sep 22, 2009
  4. grantcox macrumors newbie

    Joined:
    Oct 29, 2013
    #4
    I had the same problem, and slipstreamed USB3 drivers into the install USB. This allows me to interact with the Windows 7 setup, but at one point it reboots and boots from the install on the hard drive, not from the USB. From here on the keyboard and mouse are again unresponsive.

    I'm just going to wait for Apple to fix this - they're obviously having a few Bootcamp problems with these new Haswell machines.

    The slipstreaming process was pretty ridiculous too - download a 1.7GB disk image, to run a 60MB installer, to use a 1MB utility.
     
  5. TheKDub macrumors member

    Joined:
    Oct 30, 2008
    #5
    Hmmmm, I just got a 13" rMBP as well, just found my Win 7 disk and was about to install it via Bootcamp tonight.

    Maybe I should hold off then...
     
  6. Mefju macrumors newbie

    Joined:
    Oct 31, 2013
    #6
    Installation stucks at some point

    Hey guys, I´ve just received my brand new rMBP 13 8/256 w Mavericks and tried to install Win 7 via BootCamp and bootable usb flash drive. No matter what kind of (Win 7 64-bit) .iso I´ve tried, same thing hapens in the phase of "Expanding Windows files" - it gets stuck between 55% - 65% and nothing is happening since then on. Have to reboot and delete partition. I´ve googled a lot and tried a lot of instructions, but nowhere find the same problem and nothing helped (vram pram reset, obtain win 7 install iso without sp1 pack etc.). Does anybody have any clue what could be wrong? Really appreciate any advice, for I am pretty desperate trying again and again with a blind hope.
    Thanks!
     
  7. boylerman macrumors member

    Joined:
    Mar 17, 2010
    Location:
    Massachusetts
    #7
    I'm glad it's not just me! I just bought the 2.6 13" Haswell MBP, and am having a similar issue. Couldn't get Windows 7 to load since the keyboard and trackpad were unresponsive at boot. I even downloaded the SP1 ISO from Microsoft and had the same problem.

    I even tried to install Windows 8, and while initially the keyboard and mouse work, during the second phase of the installation process the mouse and keyboard no longer work, and I am unable to complete the installation process.

    So frustrating! Hopefully Apple gets on this and gets an update out sooner rather than later.
     
  8. boylerman macrumors member

    Joined:
    Mar 17, 2010
    Location:
    Massachusetts
    #8
    I ended up getting Windows 8 installed last night. I went ahead and deleted the Bootcamp partition using Bootcamp Assitant (after formatting it in disk utility due to an error Bootcamp Assistant through regarding the MBR on the partition.) I then restarted Bootcamp Assistant and chose the third option and it restarted the computer and booted off the USB stick. This time, the installer correctly loaded the keyboard/trackpad drivers, and the installation completed successfully.

    I don't know why that yielded a different result than running the installer by holding the CTRL from boot and selecting the USB stick, but it did. I also noticed that when setup ran successfully, it was running in native resolution, i.e., the installer program was tiny, whereas before, the installer program was scaled.
     
  9. ganomi macrumors newbie

    Joined:
    Sep 22, 2009
    #9
    Tiny = Efi boot
    Scaled = MBR boot

    Efi boot should be preferred.
     
  10. Mefju macrumors newbie

    Joined:
    Oct 31, 2013
    #10
    how do I get efi boot, please? cause I did it through bootcamp assistant and the installer was scaled.. btw. weird about this is I am not having trouble using keybord and trackpad, but the thing is it gets stuck all the time at around 55%..
     
  11. vicjang macrumors newbie

    Joined:
    Mar 17, 2014
    #11

Share This Page