Haswell Macbook Pro 15" WIFI problems

Discussion in 'MacBook Pro' started by kagux, Oct 28, 2013.

  1. kagux macrumors newbie

    Joined:
    Oct 28, 2013
    #1
    Hey guys,

    I've picked up new macbook last Friday and while updating software noticed that WIFI speeds are kinda slow. I compared speedtest.net results of the new macbook with 2009 macbook 13 sitting next to each other. To my surprise, new macbooks always gets half the speed of the old one (25 mgbs vs 50 mgbs) both for upload and download. Router is 802.11n on 2.4Ghz and I tried it on different channels.
    Both macbooks are on mavericks.

    Is that a hardware problem or a some sort of a drawback of the new ac chip?
    Has anyone of you experienced something similar?

    Thanks
     
  2. jalex19100 macrumors newbie

    Joined:
    Feb 3, 2007
    #2
    Two things to try:

    1. Add a new network location and see if that helps, although I think that's more related to issues with connecting the wifi to a router.

    2. You could try to manually set the MTU (option in the adv. tabs under the wifi network), if it's automatically picking the wrong one. An incorrectly-sized MTU will significantly slow it down. 1500 bytes is the one everyone knows, but I've seen people using 1453 at times.

    networksetup -getMTU
    networksetup -setMTU en0 1453

    refs:

    http://osxdaily.com/2013/01/14/set-mtu-size-from-the-command-line-of-mac-os-x/

    http://osxdaily.com/2012/08/02/fix-os-x-mountain-lion-wireless-connection-problems/

    Good luck!
     
  3. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #3
    Could be reception is just worse or a lot of noise.
    If you want to know all the details about the current wifi connection.
    Hold the option key and click on the wifi symbol.
    Next click wireless diagnosics at the bottom. Type in your password. Ignore the next screen. Close it with the CMD+W or the mouse.
    Hit CMD+2 to open. The tab labeled performance will show you all the readings of the current connection over time.
     
  4. kagux thread starter macrumors newbie

    Joined:
    Oct 28, 2013
    #4
    thank you guys for your suggestions!
    I looked up wifi connection details on both macbook. Old one has 802.11n at 150mgbs, while the new one has 802.11g at 54mgbs. Router has wpa2-personal security settings. MacBook 15 wifi scan results shows the AP as 802.11n.
    Both laptops are next to each other. Any ideas?
     
  5. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #5
    Try to disable compatibility mode in your router. So it only runs an 'n' an doesn't offer a fallback to 'g'.
    If you still need 'g' for other devices, it may work if you reactivate it later. It looks like some bug. Maybe the notebook just needs a kick and will remember after it connected on 'n' once.
    Maybe delete all network data in your preferences before.
    Sys prefs -> network -> wifi in the left box
    -> advanced -> delete SSID in the white box

    Security settings don't matter for your problem.
     
  6. calvol macrumors 6502a

    Joined:
    Feb 3, 2011
  7. Exen macrumors newbie

    Joined:
    Feb 24, 2009
    #7
    Just got mine yesterday and the wifi was running super slow. 3-4 mb/s. I restarted the machine once or twice and restarted my router as well. Worked like a charm (pushing 60 mb/s after that).
     
  8. zOlid macrumors regular

    zOlid

    Joined:
    Jun 13, 2013
    #8
    I have the same issue.
    All other tech in the house gets really high speed.
    But my new rMBP is getting slow speed especially over the net.
    I have a AC66U router, so i should get great speed, but I'm getting around 10-12mbit on my 100/100mbit internet line. My other electronics is getting around 97/98mbit
     
  9. kagux thread starter macrumors newbie

    Joined:
    Oct 28, 2013
    #9
    Disabling IPv6 didn't change anything, unfortunately.
    The strange thing happened when I set router to 802.11n only. My MacBook simply refused connecting to the network. I tried removing ssid and reconnecting. It asks for the password and after a while gives some meaninglessness connection problem notice with suggestion to run diagnostics.
    If it wasn't for my old macbook, I'd be blaming the router.
     
  10. double329 macrumors 6502

    Joined:
    Sep 10, 2008
    #10
    I just got mine today. With my NetGear r7000, I am getting 878mbps. I am hoping to see a little over 1000mbps though. This thing is screaming...
     

Share This Page