Have a music gig tonight: how do I...

Discussion in 'MacBook' started by kikedeolivos, Dec 20, 2009.

  1. kikedeolivos macrumors member

    Joined:
    Jun 9, 2009
    #1
    avoid my Macbook go to sleep, restart, go to login screen, etc.? I'll be playing a VST instrument from it and don't want to let me down in the middle of the set.

    Thanks a lot.
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #2
    Go to System Preferences>Energy saver and drag the sliders all the way to the right for both Battery and Power Adapter.
     
  3. kikedeolivos thread starter macrumors member

    Joined:
    Jun 9, 2009
    #3
    That's it?
    And what about the screensaver and Airport: should I disable those as well?

    Thanks
     
  4. xparaparafreakx macrumors 65816

    Joined:
    Jul 29, 2005
    #4
    Disable Airport and bluetooth if you dont need it. Leave it connected to some kind of power. Make sure your Energy Saver settings are configed for both battery and connected to power.
     

    Attached Files:

  5. kikedeolivos thread starter macrumors member

    Joined:
    Jun 9, 2009
  6. xparaparafreakx macrumors 65816

    Joined:
    Jul 29, 2005
    #6
    This might sound stupid but dont have anything else running in the background and restart the computer before your gig and only run that VST program. Restarting get back all your RAM you used.
     
  7. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #7
    ^^ It shouldn't generally be necessary as Mac OS X should swap out stuff as required. But as its important to do that can't hurt and is probably worthwhile.
     
  8. kikedeolivos thread starter macrumors member

    Joined:
    Jun 9, 2009
  9. kikedeolivos thread starter macrumors member

    Joined:
    Jun 9, 2009
    #9
    Well, something is not working as it's supposed to.

    I've setup everything per your instructions, opened iTunes Radio, choose a streams and, as usual, after maybe 30', the system restarted into to the log in screen. (haven't' touched anything during that period)...Any ideas?
     
  10. puckhead193 macrumors G3

    puckhead193

    Joined:
    May 25, 2004
    Location:
    NY
    #10
    make sure you disabled the right pref. On top it says battery/ power adapter and adjust accordingly
     
  11. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #11
    I don't have a solution, but I can tell you that something's wrong here. You're Mac is not suppose to restart to the login screen. It shouldn't ever do that regardless of your settings. Are you sure you're talking about the login screen or the dialog box to unlock your screen?
     
  12. kindablue09 macrumors regular

    kindablue09

    Joined:
    Mar 26, 2009
    #12
    Agreed, or at least I've never heard of it restarting and going to the initial log in screen. Look over the screen shots again, they should give you everything you need to know.

    Oh, and break a leg!
     
  13. kikedeolivos thread starter macrumors member

    Joined:
    Jun 9, 2009
    #13
    It's the screen where you can choose users: I have setup 2, one with a password (mine) and the other for a guest user. When this screen pops up, I can see a tick mark on mine.
     
  14. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #14
    Okay, I take back what I said about your Mac not auto logging out regardless of settings, it is possible. Try this. Go into System Preferences-Security, under the General tab make sure and uncheck (if it's IS checked) "Log Out After XX-minutes of inactivity".
     
  15. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
  16. kikedeolivos thread starter macrumors member

    Joined:
    Jun 9, 2009
    #16
    Didn't see the last answer...sigh.

    Just came back from the gig, and the Mac went to the unwanted screen. (at least, between songs) I had to log in, open Garageband, etc., etc. Thank God, the audience was patient.
     
  17. andalusia macrumors 68030

    andalusia

    Joined:
    Apr 10, 2009
    Location:
    Manchester, UK
    #17
    Wow, that must have been hard. Shame you didn't get your answer in time.
     

Share This Page