Have an .AVI container and H.264 codec but wont play in QT

Discussion in 'Digital Video' started by adotjdot, Apr 2, 2009.

  1. adotjdot macrumors newbie

    Joined:
    Apr 2, 2009
    #1
    Hi, I have a new video camera...one of those cheap HD flash drive ones, this one to be exact. It shoots 'HD' and saves those files in MPEG4 (H.264) in AVI wrapper, but they dont play in QT and in turn FCP. Seems like since it is H.264 it would work in QT, it opens and I hear sound but no video. Here is an image capture of the movie properties in QT

    http://picasaweb.google.com/lh/photo/avokysj5nAgPn7jieq3oUA?feat=directlink

    does anyone know a way to either convert it to another format (without loosing HD quality) or to get it to work in Qt or FCP?
     
  2. Kardashian macrumors 68020

    Kardashian

    Joined:
    Sep 4, 2005
    Location:
    Britain.
    #2
    When I recently ripped some BluRay movies to my Mac, I had the same problem.

    I ended up encoding them in MKV format, and not AVI, and now they play flawlessly. But, you can't do this.

    So, try this:

    Download 'Perian' for Quicktime. It installs a bunch of codes and should play the movie fine.

    Install VLC, which is what I use to watch my HD BluRay rips. It plays virtually anything you throw at it.

    Or - get a converter to convert the AVI to MPEG4 or something. Handbrake can do this I think, or something like iSquint I believe.

    Personally, I'd get VLC, and then head over to DeviantArt.com and search for the "VLC black pearl skin" which makes it look beautiful, as well as acting beautiful :)
     
  3. adotjdot thread starter macrumors newbie

    Joined:
    Apr 2, 2009
    #3
    cool thank you for the hints hopefully one of them will work. I have VLC and it works great to watch the files, I just wanted them in another format so I can edit them.

    ;) cool that your ripping Blurays!
     
  4. adotjdot thread starter macrumors newbie

    Joined:
    Apr 2, 2009

Share This Page