Have iPhone 5 on 7.1.2 and need help jailbreaking/updating

SyndicateXX

macrumors newbie
Original poster
Jun 20, 2013
17
1
So I just got an iPhone which is on 7.1.2 and I am planning to jailbreak and update it, because most of the apps requred iOS 8 or iOS 9 above.

I tried installing the 8.4 IPSW manually from iTunes but it gave error 3194.

So is there any way to update to 8.4?
 

Stefan johansson

macrumors 65816
Apr 13, 2017
1,294
606
Sweden
If you want a jailbreak,that could be difficult. If I where you,I would just go to settings-program update and update it to latest iOS version before ios11 is out,because when that iOS is rolled out,Apple will discontinue the support for iPhone 5.
 

eyoungren

macrumors Core
Aug 31, 2011
21,173
13,003
ten-zero-eleven-zero-zero by zero-two
So I just got an iPhone which is on 7.1.2 and I am planning to jailbreak and update it, because most of the apps requred iOS 8 or iOS 9 above.

I tried installing the 8.4 IPSW manually from iTunes but it gave error 3194.

So is there any way to update to 8.4?
You have two options. Upgrade or jailbreak. You cannot do both.

If you upgrade you will be forced to iOS 10.3.2 There is no jailbreak for 10.3.2 and even if there was there is a 99% chance it wouldn't apply to you because you have a 32-bit device and all the later jailbreaks are for 64-bit devices.

If you decide to jailbreak, you want Taig. If you do jailbreak, there is no updating unless you want to lose your jailbreak.

Unfortunately, just downloading an IPSW and trying to install it wll not work unless Apple is digitally signing that firmware for that device. Guess which version Apple is signing for the iPhone 5? 10.3.2 and that's it. That means 10.3.2 is your ONLY choice if you want to upgrade.

Everyone seems to think they can just jailbreak and upgrade or upgrade and jailbreak. It's not that easy.
 

SyndicateXX

macrumors newbie
Original poster
Jun 20, 2013
17
1
You have two options. Upgrade or jailbreak. You cannot do both.

If you upgrade you will be forced to iOS 10.3.2 There is no jailbreak for 10.3.2 and even if there was there is a 99% chance it wouldn't apply to you because you have a 32-bit device and all the later jailbreaks are for 64-bit devices.

If you decide to jailbreak, you want Taig. If you do jailbreak, there is no updating unless you want to lose your jailbreak.

Unfortunately, just downloading an IPSW and trying to install it wll not work unless Apple is digitally signing that firmware for that device. Guess which version Apple is signing for the iPhone 5? 10.3.2 and that's it. That means 10.3.2 is your ONLY choice if you want to upgrade.

Everyone seems to think they can just jailbreak and upgrade or upgrade and jailbreak. It's not that easy.
I jailbreaked on 7.1.2

But none of the new apps work. Instagram and many other apps.

So I dont see the point on staying on 7.1.2

Is there any other workaround to install apps on this version
or update to 8.4 ?
 

eyoungren

macrumors Core
Aug 31, 2011
21,173
13,003
ten-zero-eleven-zero-zero by zero-two
I jailbreaked on 7.1.2

But none of the new apps work. Instagram and many other apps.

So I dont see the point on staying on 7.1.2

Is there any other workaround to install apps on this version
or update to 8.4 ?
There is a workaround whereby you change the iOS version number to essentially 'fool' the system so you can download the app.

I'm not sure exactly how that's achieved (I know it involves editing a plist file), but I do know that there are two problems with it.

1. If you do not change the plist back to the correct version and then reboot the device it will no longer boot. Your only option at that point is a restore.

2. If you manage to download the app there is zero guarantee that it will work. It may use newer APIs that older versions of iOS do not have.
 

SyndicateXX

macrumors newbie
Original poster
Jun 20, 2013
17
1
There is a workaround whereby you change the iOS version number to essentially 'fool' the system so you can download the app.

I'm not sure exactly how that's achieved (I know it involves editing a plist file), but I do know that there are two problems with it.

1. If you do not change the plist back to the correct version and then reboot the device it will no longer boot. Your only option at that point is a restore.

2. If you manage to download the app there is zero guarantee that it will work. It may use newer APIs that older versions of iOS do not have.
Tried that didnt work

Am looking for a way to install 8.4

Is there any way to install 8.4 ?

If not am going to update it to the latest firmware